{"answers":{"affected":"2 open source packages ship an affected version, including yourls/yourls. It affects 1 product.","exploited":"There is no known exploitation of CVE-2021-3785 in the wild and no public exploit code.","fix":"Upgrade yourls/yourls to 1.8.2 or later.","what":"CVE-2021-3785 is a high-severity cross-site scripting vulnerability in yourls/yourls, published on 15 Sep 2021. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2021-3785 and fix it if it is affected.\n\nWhat it is: CVE-2021-3785 is a high-severity cross-site scripting vulnerability in yourls/yourls, published on 15 Sep 2021. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2021-3785 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- yourls/yourls (Packagist): affected all versions; fixed in 1.8.2\n- yourls/yourls (Packagist): affected all versions; fixed in 1.8.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2021-3785/ (Markdown: https://insights.sbomify.com/CVE-2021-3785/index.md)","id":"CVE-2021-3785","markdown":"https://insights.sbomify.com/CVE-2021-3785/index.md","name":"CVE-2021-3785","record":{"aliases":["GHSA-m9fq-c9hp-59g7"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution","account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"URL shortener","requires_auth":"low_privilege","summary":"An attacker can inject malicious scripts into the Yourls URL shortener, potentially executing code or hijacking user sessions.","user_interaction":"not_required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"@huntrdev","cpe":[{"product":"yourls","vendor":"yourls"}],"cvss":{"score":8.8,"severity":"high","source":"cna","vector":"CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H","version":"3.0"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"yourls is vulnerable to Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Cross-site Scripting (XSS) - Stored in yourls/yourls","id":"CVE-2021-3785","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"xss","year":"2021"},"n_packages":2,"n_references":2,"next":{"headline":"Information disclosure in Notebook and ThinkPad BIOS","id":"CVE-2021-3786"},"packages":[{"ecosystem":"Packagist","fixed":["1.8.2"],"introduced":["0"],"last_affected":[],"package":"yourls/yourls","purl":null,"source":"GHSA-m9fq-c9hp-59g7"},{"ecosystem":"Packagist","fixed":["1.8.2"],"introduced":["0"],"last_affected":[],"package":"yourls/yourls","purl":"pkg:composer/yourls/yourls","source":"GHSA-m9fq-c9hp-59g7"}],"prev":{"headline":"Garuda Linux Improper Authorization","id":"CVE-2021-3784"},"products":["yourls/yourls"],"published":"2021-09-15","related":[{"cvss_score":9.8,"headline":"Access of Resource Using Incompatible Type ('Type Confusion') in yourls/yourls","id":"CVE-2019-14537","kev_date_added":null,"published":"2019-08-07"},{"cvss_score":6.6,"headline":"Cross-site Scripting (XSS) - Reflected in yourls/yourls","id":"CVE-2021-3783","kev_date_added":null,"published":"2021-09-15"},{"cvss_score":6.5,"headline":"Improper Restriction of Rendered UI Layers or Frames in yourls/yourls","id":"CVE-2021-3734","kev_date_added":null,"published":"2021-08-26"},{"cvss_score":5.4,"headline":"YOURLS Stored Cross Site Scripting (XSS)","id":"CVE-2020-27388","kev_date_added":null,"published":"2020-10-23"},{"cvss_score":5,"headline":"Information disclosure in n/a","id":"CVE-2011-3824","kev_date_added":null,"published":"2011-09-24"},{"cvss_score":3.5,"headline":"Cross-Site Request Forgery (CSRF) in yourls/yourls","id":"CVE-2022-0088","kev_date_added":null,"published":"2022-04-03"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-03","vendors":["yourls"]},"summary":"An attacker can inject malicious scripts into the Yourls URL shortener, potentially executing code or hijacking user sessions.","url":"https://insights.sbomify.com/CVE-2021-3785/"}