# CVE-2021-3785: Cross-site Scripting (XSS) - Stored in yourls/yourls

> An attacker can inject malicious scripts into the Yourls URL shortener, potentially executing code or hijacking user sessions.

- **Severity:** High 8.8 (`CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 15 Sep 2021
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-m9fq-c9hp-59g7

## What is CVE-2021-3785?

CVE-2021-3785 is a high-severity cross-site scripting vulnerability in yourls/yourls, published on 15 Sep 2021. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

yourls is vulnerable to Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2021-3785?

2 open source packages ship an affected version, including yourls/yourls. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `yourls/yourls` | Packagist | All versions | 1.8.2 |
| `yourls/yourls` | Packagist | All versions | 1.8.2 |

Products: Yourls Yourls.

## How do I fix CVE-2021-3785?

Upgrade yourls/yourls to 1.8.2 or later.

## Is CVE-2021-3785 being exploited?

There is no known exploitation of CVE-2021-3785 in the wild and no public exploit code.

## Other vulnerabilities in yourls/yourls

- [CVE-2019-14537](https://insights.sbomify.com/CVE-2019-14537/): Access of Resource Using Incompatible Type ('Type Confusion') in yourls/yourls (critical 9.8)
- [CVE-2021-3783](https://insights.sbomify.com/CVE-2021-3783/): Cross-site Scripting (XSS) - Reflected in yourls/yourls (medium 6.6)
- [CVE-2021-3734](https://insights.sbomify.com/CVE-2021-3734/): Improper Restriction of Rendered UI Layers or Frames in yourls/yourls (medium 6.5)
- [CVE-2020-27388](https://insights.sbomify.com/CVE-2020-27388/): YOURLS Stored Cross Site Scripting (XSS) (medium 5.4)
- [CVE-2011-3824](https://insights.sbomify.com/CVE-2011-3824/): Information disclosure in n/a (medium 5.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-3785 and fix it if it is affected.

What it is: CVE-2021-3785 is a high-severity cross-site scripting vulnerability in yourls/yourls, published on 15 Sep 2021. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-3785 in the wild and no public exploit code.

Affected packages and fixed versions:
- yourls/yourls (Packagist): affected all versions; fixed in 1.8.2
- yourls/yourls (Packagist): affected all versions; fixed in 1.8.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-3785/ (Markdown: https://insights.sbomify.com/CVE-2021-3785/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-3785
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-3785
- OSV: https://osv.dev/vulnerability/CVE-2021-3785

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-3785/
Summaries are generated and may contain mistakes; the official description above is the record.
