# CVE-2021-37860: Cross-site Scripting in Mattermost

> An attacker can inject arbitrary web script via unsanitized clipboard contents in Mattermost deployments with disabled Content Security Policy.

- **Severity:** Low 3.7 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:U/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 22 Sep 2021
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-hv5f-73mr-7vvj, GO-2022-0604

## What is CVE-2021-37860?

CVE-2021-37860 is a low-severity cross-site scripting vulnerability in Mattermost Mattermost, published on 22 Sep 2021. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

Mattermost 5.38 and earlier fails to sufficiently sanitize clipboard contents, which allows a user-assisted attacker to inject arbitrary web script in product deployments that explicitly disable the default CSP.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2021-37860?

4 open source packages ship an affected version, including github.com/mattermost/mattermost-server/v5 and github.com/mattermost/mattermost-server. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/mattermost/mattermost-server/v5` | Go | All versions | 5.39.0 |
| `github.com/mattermost/mattermost-server/v5` | Go | All versions | 5.39.0 |
| `github.com/mattermost/mattermost-server/v5` | Go | All versions | 5.39.0 |
| `github.com/mattermost/mattermost-server` | Go | All versions | None |

Products: Mattermost Mattermost.

## How do I fix CVE-2021-37860?

Upgrade github.com/mattermost/mattermost-server/v5 to 5.39.0 or later.

## Is CVE-2021-37860 being exploited?

There is no known exploitation of CVE-2021-37860 in the wild and no public exploit code.

## Other vulnerabilities in Mattermost Mattermost

- [CVE-2019-20851](https://insights.sbomify.com/CVE-2019-20851/): Path traversal in n/a (critical 9.1)
- [CVE-2024-39274](https://insights.sbomify.com/CVE-2024-39274/): Malicious remote can add users to arbitrary teams and channels (high 8.7)
- [CVE-2024-39777](https://insights.sbomify.com/CVE-2024-39777/): Malicious remote can invite itself to an arbitrary local channel (high 8.7)
- [CVE-2024-39830](https://insights.sbomify.com/CVE-2024-39830/): Timing attack during remote cluster token comparison when shared channels are enabled (high 8.1)
- [CVE-2023-3615](https://insights.sbomify.com/CVE-2023-3615/): Lack of server certificate validation in websockets connection (high 8.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-37860 and fix it if it is affected.

What it is: CVE-2021-37860 is a low-severity cross-site scripting vulnerability in Mattermost Mattermost, published on 22 Sep 2021. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2021-37860 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/mattermost/mattermost-server/v5 (Go): affected all versions; fixed in 5.39.0
- github.com/mattermost/mattermost-server/v5 (Go): affected all versions; fixed in 5.39.0
- github.com/mattermost/mattermost-server/v5 (Go): affected all versions; fixed in 5.39.0
- github.com/mattermost/mattermost-server (Go): affected all versions; no fix listed

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-37860/ (Markdown: https://insights.sbomify.com/CVE-2021-37860/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-37860
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-37860
- OSV: https://osv.dev/vulnerability/CVE-2021-37860

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-37860/
Summaries are generated and may contain mistakes; the official description above is the record.
