{"answers":{"affected":"1 open source package ship an affected version, including mattermost. It affects 1 product.","exploited":"There is no known exploitation of CVE-2021-37863 in the wild and no public exploit code.","fix":"Upgrade mattermost to 6.0.1 or later.","what":"CVE-2021-37863 is a low-severity denial of service vulnerability in Mattermost Mattermost Server, published on 17 Dec 2021. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2021-37863 and fix it if it is affected.\n\nWhat it is: CVE-2021-37863 is a low-severity denial of service vulnerability in Mattermost Mattermost Server, published on 17 Dec 2021. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2021-37863 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- mattermost (Bitnami): affected all versions; fixed in 6.0.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2021-37863/ (Markdown: https://insights.sbomify.com/CVE-2021-37863/index.md)","id":"CVE-2021-37863","markdown":"https://insights.sbomify.com/CVE-2021-37863/index.md","name":"CVE-2021-37863","record":{"aliases":["BIT-mattermost-2021-37863","GHSA-7523-wx28-g6xf"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Mattermost chat platform","requires_auth":"low_privilege","summary":"Authenticated attackers can crash the Mattermost web client by submitting a maliciously crafted post due to insufficient parameter validation.","user_interaction":"required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"Mattermost","cpe":[{"product":"mattermost_server","vendor":"mattermost"}],"cvss":{"score":3.5,"severity":"low","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:N/I:N/A:L","version":"3.1"},"cwes":[{"id":"CWE-20","name":"Improper Input Validation"}],"description":"Mattermost 6.0 and earlier fails to sufficiently validate parameters during post creation, which allows authenticated attackers to cause a client-side crash of the web application via a maliciously crafted post.","ecosystems":["Bitnami"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Denial of service in Mattermost","id":"CVE-2021-37863","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":"mattermost:mattermost_server","products":["mattermost:mattermost_server"],"type":"denial_of_service","year":"2021"},"n_packages":1,"n_references":2,"next":{"headline":"Users can view the contents of an archived channel when access is explicitly denied by the system admin","id":"CVE-2021-37864"},"packages":[{"ecosystem":"Bitnami","fixed":["6.0.1"],"introduced":["0"],"last_affected":[],"package":"mattermost","purl":"pkg:bitnami/mattermost","source":"BIT-mattermost-2021-37863"}],"prev":{"headline":"Business logic in Mattermost","id":"CVE-2021-37862"},"products":["Mattermost"],"published":"2021-12-17","related":[{"cvss_score":9.9,"headline":"Account takeover on OAuth/OpenID-enabled servers","id":"CVE-2025-12419","kev_date_added":null,"published":"2025-11-27"},{"cvss_score":9.9,"headline":"Account Takeover via Code Exchange Endpoint","id":"CVE-2025-12421","kev_date_added":null,"published":"2025-11-27"},{"cvss_score":9.9,"headline":"Path Traversal Leading to RCE by Any Authenticated Mattermost User","id":"CVE-2025-4981","kev_date_added":null,"published":"2025-06-20"},{"cvss_score":9.9,"headline":"Arbitrary file read via block duplication in Mattermost Boards","id":"CVE-2025-20051","kev_date_added":null,"published":"2025-02-24"},{"cvss_score":9.9,"headline":"Arbitrary file read in Mattermost Boards via import \u0026 export board archive","id":"CVE-2025-25279","kev_date_added":null,"published":"2025-02-24"},{"cvss_score":9.8,"headline":"Mattermost Server: Insufficient Password-Reset Link Invalidation","id":"CVE-2016-11074","kev_date_added":null,"published":"2020-06-19"},{"cvss_score":9.8,"headline":"Mattermost Server allows attackers to gain privileges by accessing unintended API endpoints with users' credentials","id":"CVE-2017-18885","kev_date_added":null,"published":"2020-06-19"}],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-04","vendors":["Mattermost"]},"summary":"Authenticated attackers can crash the Mattermost web client by submitting a maliciously crafted post due to insufficient parameter validation.","url":"https://insights.sbomify.com/CVE-2021-37863/"}