# CVE-2021-37914: Workflow re-write vulnerability using input parameter

> Attackers can disrupt workflows via expression template injection if EXPRESSION_TEMPLATES is enabled and untrusted users control input parameters.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 2 Aug 2021
- **Updated:** 4 Aug 2024
- **Also known as:** BIT-argo-workflows-2021-37914, GHSA-h563-xh25-x54q, GO-2022-0928

## What is CVE-2021-37914?

CVE-2021-37914 is a medium-severity code injection vulnerability in n/a, published on 2 Aug 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

In Argo Workflows through 3.1.3, if EXPRESSION_TEMPLATES is enabled and untrusted users are allowed to specify input parameters when running workflows, an attacker may be able to disrupt a workflow because expression template output is evaluated.

Weakness: CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2021-37914?

6 open source packages ship an affected version, including github.com/argoproj/argo-workflows/v3, argo-workflows and github.com/argoproj/argo-workflows. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/argoproj/argo-workflows/v3` | Go | From 3.1.0 | 3.1.6 |
| `github.com/argoproj/argo-workflows/v3` | Go | From 3.1.0 | 3.1.6 |
| `github.com/argoproj/argo-workflows/v3` | Go | From 3.1.0 | 3.1.6 |
| `argo-workflows` | Bitnami | All versions | 3.1.4 |
| `github.com/argoproj/argo-workflows` | Go | All versions | None |
| `github.com/argoproj/argo-workflows/v2` | Go | All versions | None |

Products: Argoproj Argo Workflows.

## How do I fix CVE-2021-37914?

Upgrade github.com/argoproj/argo-workflows/v3 to 3.1.6 or later.

## Is CVE-2021-37914 being exploited?

There is no known exploitation of CVE-2021-37914 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2026-28229](https://insights.sbomify.com/CVE-2026-28229/): Argo Workflows has unauthorized access to Argo Workflows Template (critical 9.8)
- [CVE-2026-54526](https://insights.sbomify.com/CVE-2026-54526/): Argo Workflows: Incomplete fix for CVE-2026-31892: ArtifactGC.PodSpecPatch bypass of Strict/Secure templateReferencing (high 8.9)
- [CVE-2026-31892](https://insights.sbomify.com/CVE-2026-31892/): WorkflowTemplate Security Bypass via podSpecPatch in Strict/Secure Reference Mode (high 8.9)
- [CVE-2026-42295](https://insights.sbomify.com/CVE-2026-42295/): Argo Workflows: Exposure of artifact repository credentials (high 8.5)
- [CVE-2026-42297](https://insights.sbomify.com/CVE-2026-42297/): Argo Workflows Is Missing Authorization in Sync ConfigMap Provider (high 8.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-37914 and fix it if it is affected.

What it is: CVE-2021-37914 is a medium-severity code injection vulnerability in n/a, published on 2 Aug 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-37914 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/argoproj/argo-workflows/v3 (Go): affected from 3.1.0; fixed in 3.1.6
- github.com/argoproj/argo-workflows/v3 (Go): affected from 3.1.0; fixed in 3.1.6
- github.com/argoproj/argo-workflows/v3 (Go): affected from 3.1.0; fixed in 3.1.6
- argo-workflows (Bitnami): affected all versions; fixed in 3.1.4
- github.com/argoproj/argo-workflows (Go): affected all versions; no fix listed
- github.com/argoproj/argo-workflows/v2 (Go): affected all versions; no fix listed

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-37914/ (Markdown: https://insights.sbomify.com/CVE-2021-37914/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-37914
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-37914
- OSV: https://osv.dev/vulnerability/CVE-2021-37914

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-37914/
Summaries are generated and may contain mistakes; the official description above is the record.
