# CVE-2021-37916: Joplin vulnerable to Cross-site Scripting in notes

> Attackers can execute arbitrary scripts in Joplin via malicious note content, potentially compromising user data and application integrity.

- **Severity:** Medium 6.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 2 Aug 2021
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-mrmf-755g-w2vw

## What is CVE-2021-37916?

CVE-2021-37916 is a medium-severity cross-site scripting vulnerability in n/a, published on 2 Aug 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Joplin before 2.0.9 allows XSS via button and form in the note body.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2021-37916?

2 open source packages ship an affected version, including joplin. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `joplin` | npm | All versions | 2.0.9 |
| `joplin` | npm | All versions | 2.0.9 |

Products: Joplin Project Joplin.

## How do I fix CVE-2021-37916?

Upgrade joplin to 2.0.9 or later.

## Is CVE-2021-37916 being exploited?

There is no known exploitation of CVE-2021-37916 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2022-23340](https://insights.sbomify.com/CVE-2022-23340/): Joplin Vulnerable to Code Injection (critical 9.8)
- [CVE-2024-40643](https://insights.sbomify.com/CVE-2024-40643/): Joplin has a parsing error leading to Cross-site Scripting (XSS) (critical 9.7)
- [CVE-2023-45673](https://insights.sbomify.com/CVE-2023-45673/): Arbitrary code execution on click of PDF links in Joplin (high 8.9)
- [CVE-2025-27134](https://insights.sbomify.com/CVE-2025-27134/): Privilege escalation in Joplin server via user patch endpoint (high 8.8)
- [CVE-2023-37898](https://insights.sbomify.com/CVE-2023-37898/): Safe mode Cross-site Scripting (XSS) vulnerability in Joplin (high 8.2)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-37916 and fix it if it is affected.

What it is: CVE-2021-37916 is a medium-severity cross-site scripting vulnerability in n/a, published on 2 Aug 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2021-37916 in the wild and no public exploit code.

Affected packages and fixed versions:
- joplin (npm): affected all versions; fixed in 2.0.9
- joplin (npm): affected all versions; fixed in 2.0.9

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-37916/ (Markdown: https://insights.sbomify.com/CVE-2021-37916/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-37916
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-37916
- OSV: https://osv.dev/vulnerability/CVE-2021-37916

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-37916/
Summaries are generated and may contain mistakes; the official description above is the record.
