{"answers":{"affected":"1 open source package ship an affected version, including elasticsearch. It affects 1 product.","exploited":"There is no known exploitation of CVE-2021-37937 in the wild and no public exploit code.","fix":"Upgrade elasticsearch to 7.14.1 or later.","what":"CVE-2021-37937 is a medium-severity vulnerability in Elastic Elasticsearch, published on 22 Nov 2023. An attacker needs administrator access to exploit it, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2021-37937 and fix it if it is affected.\n\nWhat it is: CVE-2021-37937 is a medium-severity vulnerability in Elastic Elasticsearch, published on 22 Nov 2023. An attacker needs administrator access to exploit it, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2021-37937 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- elasticsearch (Bitnami): affected from 7.13.0; fixed in 7.14.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2021-37937/ (Markdown: https://insights.sbomify.com/CVE-2021-37937/index.md)","id":"CVE-2021-37937","markdown":"https://insights.sbomify.com/CVE-2021-37937/index.md","name":"CVE-2021-37937","record":{"aliases":["BIT-elasticsearch-2021-37937","GHSA-4qh7-cr89-jx92","UBUNTU-CVE-2021-37937"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["privilege_escalation"],"network_reachable":"yes","non_default_config":false,"product_category":"Elasticsearch search engine","requires_auth":"high_privilege","summary":"A compromised Fleet-Server service account can escalate privileges to super-user due to incorrect API key creation logic in Elasticsearch.","user_interaction":"not_required","vuln_class":"privilege_escalation"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"elastic","cpe":[{"product":"elasticsearch","vendor":"elastic"}],"cvss":{"score":5.9,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:U/C:H/I:H/A:N","version":"3.1"},"cwes":[{"id":"CWE-269","name":"Improper Privilege Management"}],"description":"An issue was found with how API keys are created with the Fleet-Server service account. When an API key is created with a service account, it is possible that the API key could be created with higher privileges than intended. Using this vulnerability, a compromised Fleet-Server service account could escalate themselves to a super-user.","ecosystems":["Bitnami"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Elasticsearch privilege escalation","id":"CVE-2021-37937","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":"elastic:elasticsearch","products":["elastic:elasticsearch"],"type":"privilege_escalation","year":"2021"},"n_packages":1,"n_references":2,"next":{"headline":"Path traversal in Kibana","id":"CVE-2021-37938"},"packages":[{"ecosystem":"Bitnami","fixed":["7.14.1"],"introduced":["7.13.0"],"last_affected":[],"package":"elasticsearch","purl":"pkg:bitnami/elasticsearch","source":"BIT-elasticsearch-2021-37937"}],"prev":{"headline":"Cross-site scripting in Kibana","id":"CVE-2021-37936"},"products":["Elasticsearch"],"published":"2023-11-22","related":[{"cvss_score":9.8,"headline":"Elasticsearch Groovy Scripting Engine Remote Code Execution","id":"CVE-2015-1427","kev_date_added":"2022-03-25","published":"2015-02-17"},{"cvss_score":8.1,"headline":"Elasticsearch Remote Code Execution","id":"CVE-2014-3120","kev_date_added":"2022-03-25","published":"2014-07-28"},{"cvss_score":9.8,"headline":"Code injection in n/a","id":"CVE-2015-5377","kev_date_added":null,"published":"2018-03-06"},{"cvss_score":8.8,"headline":"Deserialization of Untrusted Data in Elasticsearch Leading to Remote Code Execution","id":"CVE-2026-72649","kev_date_added":null,"published":"2026-09-01"},{"cvss_score":8.8,"headline":"Use of Out-of-range Pointer Offset in the Elasticsearch Machine Learning Native Inference Process","id":"CVE-2026-72642","kev_date_added":null,"published":"2026-08-13"},{"cvss_score":8.8,"headline":"Privilege Escalation Flaw in Elasticsearch","id":"CVE-2020-7014","kev_date_added":null,"published":"2020-06-03"},{"cvss_score":8.8,"headline":"Improper Privilege Management in Elasticsearch","id":"CVE-2020-7009","kev_date_added":null,"published":"2020-03-31"}],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-04","vendors":["Elastic"]},"summary":"A compromised Fleet-Server service account can escalate privileges to super-user due to incorrect API key creation logic in Elasticsearch.","url":"https://insights.sbomify.com/CVE-2021-37937/"}