{"answers":{"affected":"3 open source packages ship an affected version, including elastic-apm. It affects 1 product.","exploited":"There is no known exploitation of CVE-2021-37941 in the wild and no public exploit code.","fix":"Upgrade elastic-apm to 1.27.0 or later.","what":"CVE-2021-37941 is a high-severity vulnerability in Elastic APM Java Agent, published on 8 Dec 2021. It can only be exploited from the same machine or local network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2021-37941 and fix it if it is affected.\n\nWhat it is: CVE-2021-37941 is a high-severity vulnerability in Elastic APM Java Agent, published on 8 Dec 2021. It can only be exploited from the same machine or local network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2021-37941 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- elastic-apm (PyPI): affected from 1.10.0; fixed in 1.27.0\n- elastic-apm (PyPI): affected from 1.10.0; fixed in 1.27.0\n- elastic-apm (PyPI): affected from 1.10.0; fixed in 1.27.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2021-37941/ (Markdown: https://insights.sbomify.com/CVE-2021-37941/index.md)","id":"CVE-2021-37941","markdown":"https://insights.sbomify.com/CVE-2021-37941/index.md","name":"CVE-2021-37941","record":{"aliases":["GHSA-r562-m862-63w3","PYSEC-2026-634"],"analysis":{"component_type":"library","fix_type":"patch","impacts":["privilege_escalation","code_execution"],"network_reachable":"adjacent_or_local","non_default_config":true,"product_category":"APM Java Agent","requires_auth":"low_privilege","summary":"A local attacker can attach a malicious file to an application using the APM Java Agent to execute commands with elevated privileges.","user_interaction":"not_required","vuln_class":"privilege_escalation"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"elastic","cpe":[{"product":"apm_agent","vendor":"elastic"}],"cvss":{"score":7.8,"severity":"high","source":"nvd","vector":"CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-269","name":"Improper Privilege Management"}],"description":"A local privilege escalation issue was found with the APM Java agent, where a user on the system could attach a malicious file to an application running with the APM Java agent. Using this vector, a malicious or compromised user account could use the agent to run commands at a higher level of permissions than they possess. This vulnerability affects users that have set up the agent via the attacher cli 3, the attach API 2, as well as users that have enabled the profiling_inferred_spans_enabled option","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"APM Java Agent Local Privilege Escalation","id":"CVE-2021-37941","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"privilege_escalation","year":"2021"},"n_packages":3,"n_references":1,"next":{"headline":"APM Java Agent Local Privilege Escalation","id":"CVE-2021-37942"},"packages":[{"ecosystem":"PyPI","fixed":["1.27.0"],"introduced":["1.10.0"],"last_affected":[],"package":"elastic-apm","purl":null,"source":"GHSA-r562-m862-63w3"},{"ecosystem":"PyPI","fixed":["1.27.0"],"introduced":["1.10.0"],"last_affected":[],"package":"elastic-apm","purl":"pkg:pypi/elastic-apm","source":"GHSA-r562-m862-63w3"},{"ecosystem":"PyPI","fixed":["1.27.0"],"introduced":["1.10.0"],"last_affected":[],"package":"elastic-apm","purl":"pkg:pypi/elastic-apm","source":"PYSEC-2026-634"}],"prev":{"headline":"Server-side request forgery in Enterprisesearch","id":"CVE-2021-37940"},"products":["APM Java Agent"],"published":"2021-12-08","related":[{"cvss_score":7.2,"headline":"Elastic APM agent for Python client CGI proxy redirection flaw","id":"CVE-2019-7617","kev_date_added":null,"published":"2019-08-22"},{"cvss_score":2.4,"headline":"Information Disclosure in go.elastic.co/apm","id":"CVE-2021-22133","kev_date_added":null,"published":"2021-02-10"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-04","vendors":["Elastic"]},"summary":"A local attacker can attach a malicious file to an application using the APM Java Agent to execute commands with elevated privileges.","url":"https://insights.sbomify.com/CVE-2021-37941/"}