{"answers":{"affected":"4 open source packages ship an affected version, including co.elastic.apm:apm-agent-parent and co.elastic.apm:elastic-apm-agent. It affects 1 product.","exploited":"There is no known exploitation of CVE-2021-37942 in the wild and no public exploit code.","fix":"Upgrade co.elastic.apm:apm-agent-parent to 1.27.1 or later.","what":"CVE-2021-37942 is a high-severity vulnerability in Elastic APM Java Agent, published on 22 Nov 2023. It can only be exploited from the same machine or local network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2021-37942 and fix it if it is affected.\n\nWhat it is: CVE-2021-37942 is a high-severity vulnerability in Elastic APM Java Agent, published on 22 Nov 2023. It can only be exploited from the same machine or local network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2021-37942 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- co.elastic.apm:apm-agent-parent (Maven): affected from 1.18.0; fixed in 1.27.1\n- co.elastic.apm:apm-agent-parent (Maven): affected from 1.18.0; fixed in 1.27.1\n- co.elastic.apm:elastic-apm-agent (Maven): affected from 1.18.0; fixed in 1.27.1\n- co.elastic.apm:elastic-apm-agent (Maven): affected from 1.18.0; fixed in 1.27.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2021-37942/ (Markdown: https://insights.sbomify.com/CVE-2021-37942/index.md)","id":"CVE-2021-37942","markdown":"https://insights.sbomify.com/CVE-2021-37942/index.md","name":"CVE-2021-37942","record":{"aliases":["GHSA-5xqm-hc45-f2g2"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution","privilege_escalation"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"Elastic APM Java Agent","requires_auth":"low_privilege","summary":"A local attacker can attach a malicious plugin to an application using the Elastic APM Java Agent to execute code with elevated privileges.","user_interaction":"not_required","vuln_class":"privilege_escalation"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"elastic","cpe":[{"product":"apm_java_agent","vendor":"elastic"}],"cvss":{"score":7,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:L/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-269","name":"Improper Privilege Management"}],"description":"A local privilege escalation issue was found with the APM Java agent, where a user on the system could attach a malicious plugin to an application running the APM Java agent. By using this vulnerability, an attacker could execute code at a potentially higher level of permissions than their user typically has access to.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"APM Java Agent Local Privilege Escalation","id":"CVE-2021-37942","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"privilege_escalation","year":"2021"},"n_packages":4,"n_references":2,"next":{"headline":"Use after free in Chrome","id":"CVE-2021-37956"},"packages":[{"ecosystem":"Maven","fixed":["1.27.1"],"introduced":["1.18.0"],"last_affected":[],"package":"co.elastic.apm:apm-agent-parent","purl":null,"source":"GHSA-5xqm-hc45-f2g2"},{"ecosystem":"Maven","fixed":["1.27.1"],"introduced":["1.18.0"],"last_affected":[],"package":"co.elastic.apm:apm-agent-parent","purl":"pkg:maven/co.elastic.apm/apm-agent-parent","source":"GHSA-5xqm-hc45-f2g2"},{"ecosystem":"Maven","fixed":["1.27.1"],"introduced":["1.18.0"],"last_affected":[],"package":"co.elastic.apm:elastic-apm-agent","purl":null,"source":"GHSA-5xqm-hc45-f2g2"},{"ecosystem":"Maven","fixed":["1.27.1"],"introduced":["1.18.0"],"last_affected":[],"package":"co.elastic.apm:elastic-apm-agent","purl":"pkg:maven/co.elastic.apm/elastic-apm-agent","source":"GHSA-5xqm-hc45-f2g2"}],"prev":{"headline":"APM Java Agent Local Privilege Escalation","id":"CVE-2021-37941"},"products":["Elastic APM Java Agent"],"published":"2023-11-22","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-04","vendors":["Elastic"]},"summary":"A local attacker can attach a malicious plugin to an application using the Elastic APM Java Agent to execute code with elevated privileges.","url":"https://insights.sbomify.com/CVE-2021-37942/"}