# CVE-2021-37942: APM Java Agent Local Privilege Escalation

> A local attacker can attach a malicious plugin to an application using the Elastic APM Java Agent to execute code with elevated privileges.

- **Severity:** High 7.0 (`CVSS:3.1/AV:L/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 22 Nov 2023
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-5xqm-hc45-f2g2

## What is CVE-2021-37942?

CVE-2021-37942 is a high-severity vulnerability in Elastic APM Java Agent, published on 22 Nov 2023. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

A local privilege escalation issue was found with the APM Java agent, where a user on the system could attach a malicious plugin to an application running the APM Java agent. By using this vulnerability, an attacker could execute code at a potentially higher level of permissions than their user typically has access to.

Weakness: CWE-269 (Improper Privilege Management)

## Which versions are affected by CVE-2021-37942?

4 open source packages ship an affected version, including co.elastic.apm:apm-agent-parent and co.elastic.apm:elastic-apm-agent. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `co.elastic.apm:apm-agent-parent` | Maven | From 1.18.0 | 1.27.1 |
| `co.elastic.apm:apm-agent-parent` | Maven | From 1.18.0 | 1.27.1 |
| `co.elastic.apm:elastic-apm-agent` | Maven | From 1.18.0 | 1.27.1 |
| `co.elastic.apm:elastic-apm-agent` | Maven | From 1.18.0 | 1.27.1 |

Products: Elastic Apm Java Agent.

## How do I fix CVE-2021-37942?

Upgrade co.elastic.apm:apm-agent-parent to 1.27.1 or later.

## Is CVE-2021-37942 being exploited?

There is no known exploitation of CVE-2021-37942 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-37942 and fix it if it is affected.

What it is: CVE-2021-37942 is a high-severity vulnerability in Elastic APM Java Agent, published on 22 Nov 2023. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-37942 in the wild and no public exploit code.

Affected packages and fixed versions:
- co.elastic.apm:apm-agent-parent (Maven): affected from 1.18.0; fixed in 1.27.1
- co.elastic.apm:apm-agent-parent (Maven): affected from 1.18.0; fixed in 1.27.1
- co.elastic.apm:elastic-apm-agent (Maven): affected from 1.18.0; fixed in 1.27.1
- co.elastic.apm:elastic-apm-agent (Maven): affected from 1.18.0; fixed in 1.27.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-37942/ (Markdown: https://insights.sbomify.com/CVE-2021-37942/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-37942
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-37942
- OSV: https://osv.dev/vulnerability/CVE-2021-37942

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-37942/
Summaries are generated and may contain mistakes; the official description above is the record.
