{"answers":{"affected":"It affects 3 products.","exploited":"There is no known exploitation of CVE-2021-3800 in the wild and no public exploit code.","fix":"Upgrade to a fixed version.","what":"CVE-2021-3800 is a medium-severity vulnerability in Debian Debian Linux, published on 23 Aug 2022. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2021-3800 and fix it if it is affected.\n\nWhat it is: CVE-2021-3800 is a medium-severity vulnerability in Debian Debian Linux, published on 23 Aug 2022. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2021-3800 in the wild and no public exploit code.\n\nAffected product: Debian Debian Linux. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2021-3800/ (Markdown: https://insights.sbomify.com/CVE-2021-3800/index.md)","id":"CVE-2021-3800","markdown":"https://insights.sbomify.com/CVE-2021-3800/index.md","name":"CVE-2021-3800","record":{"aliases":["CLSA-2021-1640697102","CLSA-2022-1642083911","CLSA-2022-1642084196","DEBIAN-CVE-2021-3800","DLA-3110-1","GHSA-58w9-h6f7-f979","JLSEC-2025-159","SUSE-SU-2022:0828-1","UBUNTU-CVE-2021-3800","USN-5189-1"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"Glib library","requires_auth":"none","summary":"An attacker can leak content from files owned by privileged users to unprivileged users via pkexec due to a flaw in Glib.","user_interaction":"required","vuln_class":"information_disclosure"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"redhat","cpe":[{"product":"debian_linux","vendor":"debian"},{"product":"glib","vendor":"gnome"},{"product":"active_iq_unified_manager","vendor":"netapp"}],"cvss":{"score":5.5,"severity":"medium","source":"nvd","vector":"CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:N/A:N","version":"3.1"},"cwes":[{"id":"CWE-552","name":"Files or Directories Accessible to External Parties"},{"id":"CWE-200","name":"Exposure of Sensitive Information to an Unauthorized Actor"}],"description":"A flaw was found in glib before version 2.63.6. Due to random charset alias, pkexec can leak content from files owned by privileged users to unprivileged ones under the right condition.","ecosystems":["SUSE:Linux Enterprise Server 12 SP5","SUSE:Linux Enterprise Server for SAP Applications 12 SP5","SUSE:Linux Enterprise Software Development Kit 12 SP5","SUSE:Linux Enterprise Workstation Extension 12 SP5"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Information disclosure in Glib","id":"CVE-2021-3800","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":"debian:debian_linux","products":["debian:debian_linux","netapp:active_iq_unified_manager"],"type":"information_disclosure","year":"2021"},"n_packages":4,"n_references":6,"next":{"headline":"Inefficient Regular Expression Complexity in prismjs/prism","id":"CVE-2021-3801"},"packages":[{"ecosystem":"SUSE:Linux Enterprise Server 12 SP5","fixed":["2.48.2-12.25.1"],"introduced":["0"],"last_affected":[],"package":"glib2","purl":"pkg:rpm/suse/glib2\u0026distro=SUSE%20Linux%20Enterprise%20Server%2012%20SP5","source":"SUSE-SU-2022:0828-1"},{"ecosystem":"SUSE:Linux Enterprise Server for SAP Applications 12 SP5","fixed":["2.48.2-12.25.1"],"introduced":["0"],"last_affected":[],"package":"glib2","purl":"pkg:rpm/suse/glib2\u0026distro=SUSE%20Linux%20Enterprise%20Server%20for%20SAP%20Applications%2012%20SP5","source":"SUSE-SU-2022:0828-1"},{"ecosystem":"SUSE:Linux Enterprise Software Development Kit 12 SP5","fixed":["2.48.2-12.25.1"],"introduced":["0"],"last_affected":[],"package":"glib2","purl":"pkg:rpm/suse/glib2\u0026distro=SUSE%20Linux%20Enterprise%20Software%20Development%20Kit%2012%20SP5","source":"SUSE-SU-2022:0828-1"},{"ecosystem":"SUSE:Linux Enterprise Workstation Extension 12 SP5","fixed":["2.48.2-12.25.1"],"introduced":["0"],"last_affected":[],"package":"glib2","purl":"pkg:rpm/suse/glib2\u0026distro=SUSE%20Linux%20Enterprise%20Workstation%20Extension%2012%20SP5","source":"SUSE-SU-2022:0828-1"}],"prev":{"headline":"Improper Restriction of Rendered UI Layers or Frames in getgrav/grav-plugin-admin","id":"CVE-2021-3799"},"products":["Glib"],"published":"2022-08-23","related":[{"cvss_score":10,"headline":"ProFTPD Improper Access Control","id":"CVE-2015-3306","kev_date_added":"2026-10-08","published":"2015-05-18"},{"cvss_score":9.9,"headline":"RoundCube Webmail Deserialization of Untrusted Data","id":"CVE-2025-49113","kev_date_added":"2026-02-20","published":"2025-06-02"},{"cvss_score":9.8,"headline":"GNU InetUtils Argument Injection","id":"CVE-2026-24061","kev_date_added":"2026-01-26","published":"2026-01-21"},{"cvss_score":9.8,"headline":"Linux Kernel Improper Check for Unusual or Exceptional Conditions","id":"CVE-2025-39682","kev_date_added":"2026-09-18","published":"2025-09-05"},{"cvss_score":9.8,"headline":"Mozilla Firefox Use-After-Free","id":"CVE-2024-9680","kev_date_added":"2024-10-15","published":"2024-10-09"},{"cvss_score":9.8,"headline":"RARLAB UnRAR Directory Traversal","id":"CVE-2022-30333","kev_date_added":"2022-08-09","published":"2022-05-09"},{"cvss_score":9.8,"headline":"Roundcube Webmail SQL Injection","id":"CVE-2021-44026","kev_date_added":"2023-06-22","published":"2021-11-19"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"SUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-03","vendors":["n/a"]},"summary":"An attacker can leak content from files owned by privileged users to unprivileged users via pkexec due to a flaw in Glib.","url":"https://insights.sbomify.com/CVE-2021-3800/"}