{"answers":{"affected":"2 open source packages ship an affected version, including code-server. It affects 1 product.","exploited":"There is no known exploitation of CVE-2021-3810 in the wild and no public exploit code.","fix":"Upgrade code-server to 3.12.0 or later.","what":"CVE-2021-3810 is a high-severity denial of service vulnerability in cdr/code-server, published on 17 Sep 2021. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2021-3810 and fix it if it is affected.\n\nWhat it is: CVE-2021-3810 is a high-severity denial of service vulnerability in cdr/code-server, published on 17 Sep 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2021-3810 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- code-server (npm): affected all versions; fixed in 3.12.0\n- code-server (npm): affected all versions; fixed in 3.12.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2021-3810/ (Markdown: https://insights.sbomify.com/CVE-2021-3810/index.md)","id":"CVE-2021-3810","markdown":"https://insights.sbomify.com/CVE-2021-3810/index.md","name":"CVE-2021-3810","record":{"aliases":["GHSA-49x3-8228-3w3m"],"analysis":{"component_type":"developer_tool","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"code-server","requires_auth":"none","summary":"Attackers can cause denial of service in code-server by triggering inefficient regular expression complexity.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"@huntrdev","cpe":[{"product":"code-server","vendor":"coder"}],"cvss":{"score":7.5,"severity":"high","source":"cna","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","version":"3.0"},"cwes":[{"id":"CWE-1333","name":"Inefficient Regular Expression Complexity"}],"description":"code-server is vulnerable to Inefficient Regular Expression Complexity","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Inefficient Regular Expression Complexity in cdr/code-server","id":"CVE-2021-3810","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"denial_of_service","year":"2021"},"n_packages":2,"n_references":2,"next":{"headline":"Cross-site Scripting (XSS) - Reflected in pi-hole/adminlte","id":"CVE-2021-3811"},"packages":[{"ecosystem":"npm","fixed":["3.12.0"],"introduced":["0"],"last_affected":[],"package":"code-server","purl":null,"source":"GHSA-49x3-8228-3w3m"},{"ecosystem":"npm","fixed":["3.12.0"],"introduced":["0"],"last_affected":[],"package":"code-server","purl":"pkg:npm/code-server","source":"GHSA-49x3-8228-3w3m"}],"prev":{"headline":"Privilege escalation in HP PC BIOS","id":"CVE-2021-3809"},"products":["cdr/code-server"],"published":"2021-09-17","related":[{"cvss_score":8.2,"headline":"code-server vulnerable to Missing Origin Validation in WebSockets","id":"CVE-2023-26114","kev_date_added":null,"published":"2023-03-23"},{"cvss_score":6.1,"headline":"Cross site scripting in code-server","id":"CVE-2021-42648","kev_date_added":null,"published":"2022-05-11"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-03","vendors":["cdr"]},"summary":"Attackers can cause denial of service in code-server by triggering inefficient regular expression complexity.","url":"https://insights.sbomify.com/CVE-2021-3810/"}