# CVE-2021-3810: Inefficient Regular Expression Complexity in cdr/code-server

> Attackers can cause denial of service in code-server by triggering inefficient regular expression complexity.

- **Severity:** High 7.5 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 17 Sep 2021
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-49x3-8228-3w3m

## What is CVE-2021-3810?

CVE-2021-3810 is a high-severity denial of service vulnerability in cdr/code-server, published on 17 Sep 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

code-server is vulnerable to Inefficient Regular Expression Complexity

Weakness: CWE-1333 (Inefficient Regular Expression Complexity)

## Which versions are affected by CVE-2021-3810?

2 open source packages ship an affected version, including code-server. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `code-server` | npm | All versions | 3.12.0 |
| `code-server` | npm | All versions | 3.12.0 |

Products: Coder Code-Server.

## How do I fix CVE-2021-3810?

Upgrade code-server to 3.12.0 or later.

## Is CVE-2021-3810 being exploited?

There is no known exploitation of CVE-2021-3810 in the wild and no public exploit code.

## Other vulnerabilities in cdr/code-server

- [CVE-2023-26114](https://insights.sbomify.com/CVE-2023-26114/): code-server vulnerable to Missing Origin Validation in WebSockets (high 8.2)
- [CVE-2021-42648](https://insights.sbomify.com/CVE-2021-42648/): Cross site scripting in code-server (medium 6.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-3810 and fix it if it is affected.

What it is: CVE-2021-3810 is a high-severity denial of service vulnerability in cdr/code-server, published on 17 Sep 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-3810 in the wild and no public exploit code.

Affected packages and fixed versions:
- code-server (npm): affected all versions; fixed in 3.12.0
- code-server (npm): affected all versions; fixed in 3.12.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-3810/ (Markdown: https://insights.sbomify.com/CVE-2021-3810/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-3810
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-3810
- OSV: https://osv.dev/vulnerability/CVE-2021-3810

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-3810/
Summaries are generated and may contain mistakes; the official description above is the record.
