# CVE-2021-38148: Obsidian does not require user confirmation for non-http/https URLs.

> Obsidian fails to prompt for confirmation on non-http/https URLs, allowing potential security bypasses via malicious links.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 7 Aug 2021
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-45mx-g85m-wwm3

## What is CVE-2021-38148?

CVE-2021-38148 is a critical vulnerability in n/a, published on 7 Aug 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Obsidian before 0.12.12 does not require user confirmation for non-http/https URLs.

## Which versions are affected by CVE-2021-38148?

2 open source packages ship an affected version, including obsidian. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `obsidian` | npm | All versions | 0.12.12 |
| `obsidian` | npm | All versions | 0.12.12 |

Products: Obsidian Obsidian.

## How do I fix CVE-2021-38148?

Upgrade obsidian to 0.12.12 or later.

## Is CVE-2021-38148 being exploited?

There is no known exploitation of CVE-2021-38148 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2023-2110](https://insights.sbomify.com/CVE-2023-2110/): Obsidian Local File Disclosure (high 8.2)
- [CVE-2023-33244](https://insights.sbomify.com/CVE-2023-33244/): Security feature bypass in n/a (high 8.2)
- [CVE-2022-36450](https://insights.sbomify.com/CVE-2022-36450/): Code injection in n/a (high 8.0)
- [CVE-2023-27035](https://insights.sbomify.com/CVE-2023-27035/): Other in n/a (medium 6.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-38148 and fix it if it is affected.

What it is: CVE-2021-38148 is a critical vulnerability in n/a, published on 7 Aug 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-38148 in the wild and no public exploit code.

Affected packages and fixed versions:
- obsidian (npm): affected all versions; fixed in 0.12.12
- obsidian (npm): affected all versions; fixed in 0.12.12

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-38148/ (Markdown: https://insights.sbomify.com/CVE-2021-38148/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-38148
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-38148
- OSV: https://osv.dev/vulnerability/CVE-2021-38148

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-38148/
Summaries are generated and may contain mistakes; the official description above is the record.
