# CVE-2021-3815: Prototype Pollution in fabiocaccamo/utils.js

> Prototype pollution in fabiocaccamo/utils.js allows attackers to modify object prototypes, potentially leading to code execution or security bypasses.

- **Severity:** High 8.0 (`CVSS:3.0/AV:L/AC:L/PR:N/UI:N/S:U/C:L/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 8 Dec 2021
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-3xph-cp8f-2229

## What is CVE-2021-3815?

CVE-2021-3815 is a high-severity vulnerability in fabiocaccamo/utils.js, published on 8 Dec 2021. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

utils.js is vulnerable to Improperly Controlled Modification of Object Prototype Attributes ('Prototype Pollution')

Weakness: CWE-1321 (Improperly Controlled Modification of Object Prototype Attributes)

## Which versions are affected by CVE-2021-3815?

2 open source packages ship an affected version, including @fabiocaccamo/utils.js. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@fabiocaccamo/utils.js` | npm | All versions | 0.17.2 |
| `@fabiocaccamo/utils.js` | npm | All versions | 0.17.2 |

Products: Utils.js Project Utils.js.

## How do I fix CVE-2021-3815?

Upgrade @fabiocaccamo/utils.js to 0.17.2 or later.

## Is CVE-2021-3815 being exploited?

There is no known exploitation of CVE-2021-3815 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-3815 and fix it if it is affected.

What it is: CVE-2021-3815 is a high-severity vulnerability in fabiocaccamo/utils.js, published on 8 Dec 2021. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-3815 in the wild and no public exploit code.

Affected packages and fixed versions:
- @fabiocaccamo/utils.js (npm): affected all versions; fixed in 0.17.2
- @fabiocaccamo/utils.js (npm): affected all versions; fixed in 0.17.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-3815/ (Markdown: https://insights.sbomify.com/CVE-2021-3815/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-3815
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-3815
- OSV: https://osv.dev/vulnerability/CVE-2021-3815

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-3815/
Summaries are generated and may contain mistakes; the official description above is the record.
