# CVE-2021-38153: Timing Attack Vulnerability for Apache Kafka Connect and Clients

> Timing attacks on password validation allow attackers to brute force credentials, potentially leading to unauthorized access to Apache Kafka Connect and clients.

- **Severity:** Medium 5.9 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 22 Sep 2021
- **Updated:** 4 Aug 2024
- **Also known as:** BIT-kafka-2021-38153, GHSA-3j6g-hxx5-3q26, UBUNTU-CVE-2021-38153

## What is CVE-2021-38153?

CVE-2021-38153 is a medium-severity vulnerability in Oracle Communications Cloud Native Core Policy, published on 22 Sep 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Some components in Apache Kafka use `Arrays.equals` to validate a password or key, which is vulnerable to timing attacks that make brute force attacks for such credentials more likely to be successful. Users should upgrade to 2.8.1 or higher, or 3.0.0 or higher where this vulnerability has been fixed. The affected versions include Apache Kafka 2.0.0, 2.0.1, 2.1.0, 2.1.1, 2.2.0, 2.2.1, 2.2.2, 2.3.0, 2.3.1, 2.4.0, 2.4.1, 2.5.0, 2.5.1, 2.6.0, 2.6.1, 2.6.2, 2.7.0, 2.7.1, and 2.8.0.

Weakness: CWE-203 (Observable Discrepancy)

## Which versions are affected by CVE-2021-38153?

21 open source packages ship an affected version, including org.apache.kafka:kafka-clients, kafka and org.apache.kafka:kafka_2.11. It affects 8 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.kafka:kafka-clients` | Maven | From 2.0.0 | 2.6.3 |
| `org.apache.kafka:kafka-clients` | Maven | From 2.0.0 | 2.6.3 |
| `org.apache.kafka:kafka-clients` | Maven | From 2.7.0 | 2.7.2 |
| `org.apache.kafka:kafka-clients` | Maven | From 2.7.0 | 2.7.2 |
| `org.apache.kafka:kafka-clients` | Maven | From 2.8.0 | 2.8.1 |
| `org.apache.kafka:kafka-clients` | Maven | From 2.8.0 | 2.8.1 |
| `kafka` | Bitnami | From 2.0.0 | 2.6.3, 2.7.2, 2.8.1 |
| `org.apache.kafka:kafka_2.11` | Maven | From 2.0.0 to 2.4.1 | None |
| `org.apache.kafka:kafka_2.11` | Maven | From 2.0.0 to 2.4.1 | None |
| `org.apache.kafka:kafka_2.12` | Maven | From 2.0.0 | 2.6.3 |
| `org.apache.kafka:kafka_2.12` | Maven | From 2.0.0 | 2.6.3 |
| `org.apache.kafka:kafka_2.12` | Maven | From 2.7.0 | 2.7.2 |
| `org.apache.kafka:kafka_2.12` | Maven | From 2.7.0 | 2.7.2 |
| `org.apache.kafka:kafka_2.12` | Maven | From 2.8.0 | 2.8.1 |
| `org.apache.kafka:kafka_2.12` | Maven | From 2.8.0 | 2.8.1 |
| `org.apache.kafka:kafka_2.13` | Maven | From 2.4.0 | 2.6.3 |
| `org.apache.kafka:kafka_2.13` | Maven | From 2.4.0 | 2.6.3 |
| `org.apache.kafka:kafka_2.13` | Maven | From 2.7.0 | 2.7.2 |
| `org.apache.kafka:kafka_2.13` | Maven | From 2.7.0 | 2.7.2 |
| `org.apache.kafka:kafka_2.13` | Maven | From 2.8.0 | 2.8.1 |
| `org.apache.kafka:kafka_2.13` | Maven | From 2.8.0 | 2.8.1 |

Products: Apache Kafka, Oracle Communications Brm - Elastic Charging Engine, Oracle Communications Cloud Native Core Policy, Oracle Financial Services Analytical Applications Infrastructure, Oracle Financial Services Behavior Detection Platform, Oracle Financial Services Enterprise Case Management, Oracle Primavera Unifier, Quarkus Quarkus.

## How do I fix CVE-2021-38153?

Upgrade org.apache.kafka:kafka-clients to a fixed version for your release line: 2.6.3, 2.7.2 or 2.8.1.

## Is CVE-2021-38153 being exploited?

There is no known exploitation of CVE-2021-38153 in the wild and no public exploit code.

## Other vulnerabilities in Oracle Communications Cloud Native Core Policy

- [CVE-2026-33557](https://insights.sbomify.com/CVE-2026-33557/): Apache Kafka: Missing JWT token validation in OAUTHBEARER authentication (critical 9.1)
- [CVE-2025-27818](https://insights.sbomify.com/CVE-2025-27818/): Apache Kafka: Possible RCE attack via SASL JAAS LdapLoginModule configuration (high 8.8)
- [CVE-2018-17196](https://insights.sbomify.com/CVE-2018-17196/): Improper Input Validation in Apache Kafka (high 8.8)
- [CVE-2026-35554](https://insights.sbomify.com/CVE-2026-35554/): Apache Kafka Clients: Kafka Producer Message Corruption and Misrouting via Buffer Pool Race Condition (high 8.7)
- [CVE-2025-27817](https://insights.sbomify.com/CVE-2025-27817/): Apache Kafka Client: Arbitrary file read and SSRF vulnerability (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-38153 and fix it if it is affected.

What it is: CVE-2021-38153 is a medium-severity vulnerability in Oracle Communications Cloud Native Core Policy, published on 22 Sep 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-38153 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.kafka:kafka-clients (Maven): affected from 2.0.0; fixed in 2.6.3
- org.apache.kafka:kafka-clients (Maven): affected from 2.0.0; fixed in 2.6.3
- org.apache.kafka:kafka-clients (Maven): affected from 2.7.0; fixed in 2.7.2
- org.apache.kafka:kafka-clients (Maven): affected from 2.7.0; fixed in 2.7.2
- org.apache.kafka:kafka-clients (Maven): affected from 2.8.0; fixed in 2.8.1
- org.apache.kafka:kafka-clients (Maven): affected from 2.8.0; fixed in 2.8.1
- kafka (Bitnami): affected from 2.0.0; fixed in 2.6.3, 2.7.2, 2.8.1
- org.apache.kafka:kafka_2.11 (Maven): affected from 2.0.0 up to 2.4.1; no fix listed
- org.apache.kafka:kafka_2.11 (Maven): affected from 2.0.0 up to 2.4.1; no fix listed
- org.apache.kafka:kafka_2.12 (Maven): affected from 2.0.0; fixed in 2.6.3
- org.apache.kafka:kafka_2.12 (Maven): affected from 2.0.0; fixed in 2.6.3
- org.apache.kafka:kafka_2.12 (Maven): affected from 2.7.0; fixed in 2.7.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-38153/ (Markdown: https://insights.sbomify.com/CVE-2021-38153/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-38153
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-38153
- OSV: https://osv.dev/vulnerability/CVE-2021-38153

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-38153/
Summaries are generated and may contain mistakes; the official description above is the record.
