CVE-2021-38155 OpenStack Keystone allows information disclosure during account locking
Unauthenticated attackers can confirm account existence and obtain UUIDs by guessing names and failing authentication, requiring enabled lockout features.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2021-38155?
CVE-2021-38155 is a high-severity vulnerability in n/a, published on 6 Aug 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
OpenStack Keystone 10.x through 16.x before 16.0.2, 17.x before 17.0.1, 18.x before 18.0.1, and 19.x before 19.0.1 allows information disclosure during account locking (related to PCI DSS features). By guessing the name of an account and failing to authenticate multiple times, any unauthenticated actor could both confirm the account exists and obtain that account's corresponding UUID, which might be leveraged for other unrelated attacks. All deployments enabling security_compliance.lockout_failure_attempts are affected.
Weakness: CWE-307
Which versions are affected by CVE-2021-38155?
9 open source packages ship an affected version, including keystone. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
keystone PyPI | From 10.0 | 16.0.2, 17.0.1, 18.0.1, 19.0.1 |
keystone PyPI | From 10.0 | 16.0.2 |
keystone PyPI | From 10.0 | 16.0.2 |
keystone PyPI | From 17.0 | 17.0.1 |
keystone PyPI | From 17.0 | 17.0.1 |
keystone PyPI | From 18.0 | 18.0.1 |
3 more packages
keystone PyPI | From 18.0 | 18.0.1 |
keystone PyPI | From 19.0 | 19.0.1 |
keystone PyPI | From 19.0 | 19.0.1 |
Products include Openstack Keystone.
How do I fix CVE-2021-38155?
Upgrade keystone to a fixed version for your release line: 16.0.2, 17.0.1, 18.0.1 or 19.0.1.
Is CVE-2021-38155 being exploited?
There is no known exploitation of CVE-2021-38155 in the wild and no public exploit code.
Other vulnerabilities in n/a
- CVE-2020-12690 Insufficient Session Expiration in OpenStack Keystone
- CVE-2019-19687 OpenStack Keystone Credential Leakage
- CVE-2026-43001 OpenStack Keystone has an Incorrect Authorization Issue
- CVE-2014-2828 OpenStack Identity (Keystone) DoS through V3 API authentication chaining
- CVE-2015-7546 OpenStack Identity Keystone and keystonemiddleware Insufficiently Protected Credentials
Sources
Also known as DEBIAN-CVE-2021-38155, GHSA-4225-97pr-rr52, PYSEC-2026-830, UBUNTU-CVE-2021-38155.