# CVE-2021-38155: OpenStack Keystone allows information disclosure during account locking

> Unauthenticated attackers can confirm account existence and obtain UUIDs by guessing names and failing authentication, requiring enabled lockout features.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 6 Aug 2021
- **Updated:** 4 Aug 2024
- **Also known as:** DEBIAN-CVE-2021-38155, GHSA-4225-97pr-rr52, PYSEC-2026-830, UBUNTU-CVE-2021-38155

## What is CVE-2021-38155?

CVE-2021-38155 is a high-severity vulnerability in n/a, published on 6 Aug 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

OpenStack Keystone 10.x through 16.x before 16.0.2, 17.x before 17.0.1, 18.x before 18.0.1, and 19.x before 19.0.1 allows information disclosure during account locking (related to PCI DSS features). By guessing the name of an account and failing to authenticate multiple times, any unauthenticated actor could both confirm the account exists and obtain that account's corresponding UUID, which might be leveraged for other unrelated attacks. All deployments enabling security_compliance.lockout_failure_attempts are affected.

Weakness: CWE-307 (Improper Restriction of Excessive Authentication Attempts)

## Which versions are affected by CVE-2021-38155?

9 open source packages ship an affected version, including keystone. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `keystone` | PyPI | From 10.0 | 16.0.2, 17.0.1, 18.0.1, 19.0.1 |
| `keystone` | PyPI | From 10.0 | 16.0.2 |
| `keystone` | PyPI | From 10.0 | 16.0.2 |
| `keystone` | PyPI | From 17.0 | 17.0.1 |
| `keystone` | PyPI | From 17.0 | 17.0.1 |
| `keystone` | PyPI | From 18.0 | 18.0.1 |
| `keystone` | PyPI | From 18.0 | 18.0.1 |
| `keystone` | PyPI | From 19.0 | 19.0.1 |
| `keystone` | PyPI | From 19.0 | 19.0.1 |

Products: Openstack Keystone.

## How do I fix CVE-2021-38155?

Upgrade keystone to a fixed version for your release line: 16.0.2, 17.0.1, 18.0.1 or 19.0.1.

## Is CVE-2021-38155 being exploited?

There is no known exploitation of CVE-2021-38155 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2020-12690](https://insights.sbomify.com/CVE-2020-12690/): Insufficient Session Expiration in OpenStack Keystone (high 8.8)
- [CVE-2019-19687](https://insights.sbomify.com/CVE-2019-19687/): OpenStack Keystone Credential Leakage (high 8.8)
- [CVE-2026-43001](https://insights.sbomify.com/CVE-2026-43001/): OpenStack Keystone has an Incorrect Authorization Issue (high 7.9)
- [CVE-2014-2828](https://insights.sbomify.com/CVE-2014-2828/): OpenStack Identity (Keystone) DoS through V3 API authentication chaining (high 7.8)
- [CVE-2015-7546](https://insights.sbomify.com/CVE-2015-7546/): OpenStack Identity Keystone and keystonemiddleware Insufficiently Protected Credentials (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-38155 and fix it if it is affected.

What it is: CVE-2021-38155 is a high-severity vulnerability in n/a, published on 6 Aug 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-38155 in the wild and no public exploit code.

Affected packages and fixed versions:
- keystone (PyPI): affected from 10.0; fixed in 16.0.2, 17.0.1, 18.0.1, 19.0.1
- keystone (PyPI): affected from 10.0; fixed in 16.0.2
- keystone (PyPI): affected from 10.0; fixed in 16.0.2
- keystone (PyPI): affected from 17.0; fixed in 17.0.1
- keystone (PyPI): affected from 17.0; fixed in 17.0.1
- keystone (PyPI): affected from 18.0; fixed in 18.0.1
- keystone (PyPI): affected from 18.0; fixed in 18.0.1
- keystone (PyPI): affected from 19.0; fixed in 19.0.1
- keystone (PyPI): affected from 19.0; fixed in 19.0.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-38155/ (Markdown: https://insights.sbomify.com/CVE-2021-38155/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-38155
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-38155
- OSV: https://osv.dev/vulnerability/CVE-2021-38155

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-38155/
Summaries are generated and may contain mistakes; the official description above is the record.
