# CVE-2021-38186: Cross-site Scripting in comrak

> Attackers can execute arbitrary scripts in user browsers by exploiting improper handling of HTML entities in the comrak Rust library.

- **Severity:** Medium 6.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 8 Aug 2021
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-6wj2-g87r-pm62, RUSTSEC-2021-0063

## What is CVE-2021-38186?

CVE-2021-38186 is a medium-severity cross-site scripting vulnerability in n/a, published on 8 Aug 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

An issue was discovered in the comrak crate before 0.10.1 for Rust. It mishandles & characters, leading to XSS via &# HTML entities.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2021-38186?

3 open source packages ship an affected version, including comrak. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `comrak` | crates.io | All versions | 0.10.1 |
| `comrak` | crates.io | All versions | 0.10.1 |
| `comrak` | crates.io | From 0.0.0-0 | 0.10.1 |

Products: Comrak Project Comrak.

## How do I fix CVE-2021-38186?

Upgrade comrak to 0.10.1 or later.

## Is CVE-2021-38186 being exploited?

There is no known exploitation of CVE-2021-38186 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2021-27671](https://insights.sbomify.com/CVE-2021-27671/): Cross site scripting in comrak (medium 6.1)
- [CVE-2023-28626](https://insights.sbomify.com/CVE-2023-28626/): Quadratic runtime when parsing Markdown in comrak (medium 5.3)
- [CVE-2023-28631](https://insights.sbomify.com/CVE-2023-28631/): Attacker controlled data in AST nodes is not validated in comrak (medium 5.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-38186 and fix it if it is affected.

What it is: CVE-2021-38186 is a medium-severity cross-site scripting vulnerability in n/a, published on 8 Aug 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2021-38186 in the wild and no public exploit code.

Affected packages and fixed versions:
- comrak (crates.io): affected all versions; fixed in 0.10.1
- comrak (crates.io): affected all versions; fixed in 0.10.1
- comrak (crates.io): affected from 0.0.0-0; fixed in 0.10.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-38186/ (Markdown: https://insights.sbomify.com/CVE-2021-38186/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-38186
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-38186
- OSV: https://osv.dev/vulnerability/CVE-2021-38186

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-38186/
Summaries are generated and may contain mistakes; the official description above is the record.
