# CVE-2021-38192: Overflow in prost-types

> An integer overflow in the prost-types Rust library during timestamp conversion can cause a denial of service.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 8 Aug 2021
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-x4qm-mcjq-v2gf, RUSTSEC-2021-0073

## What is CVE-2021-38192?

CVE-2021-38192 is a high-severity vulnerability in n/a, published on 8 Aug 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

An issue was discovered in the prost-types crate before 0.8.0 for Rust. An overflow can occur during conversion from Timestamp to SystemTime.

Weakness: CWE-120 (Buffer Copy without Checking Size of Input)

## Which versions are affected by CVE-2021-38192?

3 open source packages ship an affected version, including prost-types. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `prost-types` | crates.io | All versions | 0.8.0 |
| `prost-types` | crates.io | All versions | 0.8.0 |
| `prost-types` | crates.io | From 0.0.0-0 | 0.8.0 |

Products: Prost Project Prost.

## How do I fix CVE-2021-38192?

Upgrade prost-types to 0.8.0 or later.

## Is CVE-2021-38192 being exploited?

There is no known exploitation of CVE-2021-38192 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2020-35858](https://insights.sbomify.com/CVE-2020-35858/): Out of bounds write in prost (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-38192 and fix it if it is affected.

What it is: CVE-2021-38192 is a high-severity vulnerability in n/a, published on 8 Aug 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-38192 in the wild and no public exploit code.

Affected packages and fixed versions:
- prost-types (crates.io): affected all versions; fixed in 0.8.0
- prost-types (crates.io): affected all versions; fixed in 0.8.0
- prost-types (crates.io): affected from 0.0.0-0; fixed in 0.8.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-38192/ (Markdown: https://insights.sbomify.com/CVE-2021-38192/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-38192
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-38192
- OSV: https://osv.dev/vulnerability/CVE-2021-38192

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-38192/
Summaries are generated and may contain mistakes; the official description above is the record.
