{"answers":{"affected":"3 open source packages ship an affected version, including libsecp256k1. It affects 1 product.","exploited":"There is no known exploitation of CVE-2021-38195 in the wild and no public exploit code.","fix":"Upgrade libsecp256k1 to 0.5.0 or later.","what":"CVE-2021-38195 is a critical vulnerability in n/a, published on 8 Aug 2021. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2021-38195 and fix it if it is affected.\n\nWhat it is: CVE-2021-38195 is a critical vulnerability in n/a, published on 8 Aug 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2021-38195 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- libsecp256k1 (crates.io): affected all versions; fixed in 0.5.0\n- libsecp256k1 (crates.io): affected all versions; fixed in 0.5.0\n- libsecp256k1 (crates.io): affected from 0.0.0-0; fixed in 0.5.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2021-38195/ (Markdown: https://insights.sbomify.com/CVE-2021-38195/index.md)","id":"CVE-2021-38195","markdown":"https://insights.sbomify.com/CVE-2021-38195/index.md","name":"CVE-2021-38195","record":{"aliases":["GHSA-g4vj-x7v9-h82m","RUSTSEC-2021-0076"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"Rust crypto library","requires_auth":"none","summary":"The libsecp256k1 Rust library incorrectly verifies invalid signatures by allowing parameters to exceed the curve order, bypassing cryptographic validation.","user_interaction":"not_required","vuln_class":"other"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"libsecp256k1","vendor":"parity"}],"cvss":{"score":9.8,"severity":"critical","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-347","name":"Improper Verification of Cryptographic Signature"}],"description":"An issue was discovered in the libsecp256k1 crate before 0.5.0 for Rust. It can verify an invalid signature because it allows the R or S parameter to be larger than the curve order, aka an overflow.","ecosystems":["crates.io"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Overflow in libsecp256k1","id":"CVE-2021-38195","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"crates.io","product":null,"products":[],"type":"other","year":"2021"},"n_packages":3,"n_references":2,"next":{"headline":"Remote code execution in better-macro","id":"CVE-2021-38196"},"packages":[{"ecosystem":"crates.io","fixed":["0.5.0"],"introduced":["0"],"last_affected":[],"package":"libsecp256k1","purl":null,"source":"GHSA-g4vj-x7v9-h82m"},{"ecosystem":"crates.io","fixed":["0.5.0"],"introduced":["0"],"last_affected":[],"package":"libsecp256k1","purl":"pkg:cargo/libsecp256k1","source":"GHSA-g4vj-x7v9-h82m"},{"ecosystem":"crates.io","fixed":["0.5.0"],"introduced":["0.0.0-0"],"last_affected":[],"package":"libsecp256k1","purl":"pkg:cargo/libsecp256k1","source":"RUSTSEC-2021-0076"}],"prev":{"headline":"Calculation error in ark-r1cs-std","id":"CVE-2021-38194"},"products":["n/a"],"published":"2021-08-08","related":[{"cvss_score":7.5,"headline":"libsecp256k1 contains side-channel timing attack","id":"CVE-2019-25003","kev_date_added":null,"published":"2020-12-31"},{"cvss_score":5.9,"headline":"Observable Discrepancy in libsecp256k1-rs","id":"CVE-2019-20399","kev_date_added":null,"published":"2020-01-22"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"open","licence":"CC0 1.0","name":"RustSec","prefix":"RUSTSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-04","vendors":["n/a"]},"summary":"The libsecp256k1 Rust library incorrectly verifies invalid signatures by allowing parameters to exceed the curve order, bypassing cryptographic validation.","url":"https://insights.sbomify.com/CVE-2021-38195/"}