# CVE-2021-38195: Overflow in libsecp256k1

> The libsecp256k1 Rust library incorrectly verifies invalid signatures by allowing parameters to exceed the curve order, bypassing cryptographic validation.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 8 Aug 2021
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-g4vj-x7v9-h82m, RUSTSEC-2021-0076

## What is CVE-2021-38195?

CVE-2021-38195 is a critical vulnerability in n/a, published on 8 Aug 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

An issue was discovered in the libsecp256k1 crate before 0.5.0 for Rust. It can verify an invalid signature because it allows the R or S parameter to be larger than the curve order, aka an overflow.

Weakness: CWE-347 (Improper Verification of Cryptographic Signature)

## Which versions are affected by CVE-2021-38195?

3 open source packages ship an affected version, including libsecp256k1. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `libsecp256k1` | crates.io | All versions | 0.5.0 |
| `libsecp256k1` | crates.io | All versions | 0.5.0 |
| `libsecp256k1` | crates.io | From 0.0.0-0 | 0.5.0 |

Products: Parity Libsecp256k1.

## How do I fix CVE-2021-38195?

Upgrade libsecp256k1 to 0.5.0 or later.

## Is CVE-2021-38195 being exploited?

There is no known exploitation of CVE-2021-38195 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2019-25003](https://insights.sbomify.com/CVE-2019-25003/): libsecp256k1 contains side-channel timing attack (high 7.5)
- [CVE-2019-20399](https://insights.sbomify.com/CVE-2019-20399/): Observable Discrepancy in libsecp256k1-rs (medium 5.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-38195 and fix it if it is affected.

What it is: CVE-2021-38195 is a critical vulnerability in n/a, published on 8 Aug 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-38195 in the wild and no public exploit code.

Affected packages and fixed versions:
- libsecp256k1 (crates.io): affected all versions; fixed in 0.5.0
- libsecp256k1 (crates.io): affected all versions; fixed in 0.5.0
- libsecp256k1 (crates.io): affected from 0.0.0-0; fixed in 0.5.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-38195/ (Markdown: https://insights.sbomify.com/CVE-2021-38195/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-38195
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-38195
- OSV: https://osv.dev/vulnerability/CVE-2021-38195

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-38195/
Summaries are generated and may contain mistakes; the official description above is the record.
