{"answers":{"affected":"2 open source packages ship an affected version, including i. It affects 1 product.","exploited":"There is no known exploitation of CVE-2021-3820 in the wild and no public exploit code.","fix":"Upgrade i to 0.3.7 or later.","what":"CVE-2021-3820 is a medium-severity denial of service vulnerability in pksunkara/inflect, published on 27 Sep 2021. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2021-3820 and fix it if it is affected.\n\nWhat it is: CVE-2021-3820 is a medium-severity denial of service vulnerability in pksunkara/inflect, published on 27 Sep 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2021-3820 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- i (npm): affected all versions; fixed in 0.3.7\n- i (npm): affected all versions; fixed in 0.3.7\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2021-3820/ (Markdown: https://insights.sbomify.com/CVE-2021-3820/index.md)","id":"CVE-2021-3820","markdown":"https://insights.sbomify.com/CVE-2021-3820/index.md","name":"CVE-2021-3820","record":{"aliases":["GHSA-x55w-vjjp-222r"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"JavaScript inflection library","requires_auth":"none","summary":"Attackers can cause denial of service in applications using the inflect library by triggering inefficient regular expression complexity.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"@huntrdev","cpe":[{"product":"inflect","vendor":"inflect_project"}],"cvss":{"score":5.3,"severity":"medium","source":"cna","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L","version":"3.0"},"cwes":[{"id":"CWE-1333","name":"Inefficient Regular Expression Complexity"}],"description":"inflect is vulnerable to Inefficient Regular Expression Complexity","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Inefficient Regular Expression Complexity in pksunkara/inflect","id":"CVE-2021-3820","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"denial_of_service","year":"2021"},"n_packages":2,"n_references":2,"next":{"headline":"Denial of service in HP FutureSmart","id":"CVE-2021-3821"},"packages":[{"ecosystem":"npm","fixed":["0.3.7"],"introduced":["0"],"last_affected":[],"package":"i","purl":null,"source":"GHSA-x55w-vjjp-222r"},{"ecosystem":"npm","fixed":["0.3.7"],"introduced":["0"],"last_affected":[],"package":"i","purl":"pkg:npm/i","source":"GHSA-x55w-vjjp-222r"}],"prev":{"headline":"Cross-Site Request Forgery (CSRF) in firefly-iii/firefly-iii","id":"CVE-2021-3819"},"products":["pksunkara/inflect"],"published":"2021-09-27","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-03","vendors":["pksunkara"]},"summary":"Attackers can cause denial of service in applications using the inflect library by triggering inefficient regular expression complexity.","url":"https://insights.sbomify.com/CVE-2021-3820/"}