# CVE-2021-3820: Inefficient Regular Expression Complexity in pksunkara/inflect

> Attackers can cause denial of service in applications using the inflect library by triggering inefficient regular expression complexity.

- **Severity:** Medium 5.3 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 27 Sep 2021
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-x55w-vjjp-222r

## What is CVE-2021-3820?

CVE-2021-3820 is a medium-severity denial of service vulnerability in pksunkara/inflect, published on 27 Sep 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

inflect is vulnerable to Inefficient Regular Expression Complexity

Weakness: CWE-1333 (Inefficient Regular Expression Complexity)

## Which versions are affected by CVE-2021-3820?

2 open source packages ship an affected version, including i. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `i` | npm | All versions | 0.3.7 |
| `i` | npm | All versions | 0.3.7 |

Products: Inflect Project Inflect.

## How do I fix CVE-2021-3820?

Upgrade i to 0.3.7 or later.

## Is CVE-2021-3820 being exploited?

There is no known exploitation of CVE-2021-3820 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-3820 and fix it if it is affected.

What it is: CVE-2021-3820 is a medium-severity denial of service vulnerability in pksunkara/inflect, published on 27 Sep 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-3820 in the wild and no public exploit code.

Affected packages and fixed versions:
- i (npm): affected all versions; fixed in 0.3.7
- i (npm): affected all versions; fixed in 0.3.7

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-3820/ (Markdown: https://insights.sbomify.com/CVE-2021-3820/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-3820
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-3820
- OSV: https://osv.dev/vulnerability/CVE-2021-3820

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-3820/
Summaries are generated and may contain mistakes; the official description above is the record.
