# CVE-2021-3822: Inefficient Regular Expression Complexity in josdejong/jsoneditor

> Attackers can cause denial of service in josdejong/jsoneditor by triggering inefficient regular expression complexity.

- **Severity:** Medium 5.3 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 27 Sep 2021
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-hhfg-6hfc-rvxm

## What is CVE-2021-3822?

CVE-2021-3822 is a medium-severity denial of service vulnerability in josdejong/jsoneditor, published on 27 Sep 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

jsoneditor is vulnerable to Inefficient Regular Expression Complexity

Weakness: CWE-400 (Uncontrolled Resource Consumption), CWE-1333 (Inefficient Regular Expression Complexity)

## Which versions are affected by CVE-2021-3822?

2 open source packages ship an affected version, including jsoneditor. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `jsoneditor` | npm | All versions | 9.5.6 |
| `jsoneditor` | npm | All versions | 9.5.6 |

Products: Jsoneditoronline Jsoneditor.

## How do I fix CVE-2021-3822?

Upgrade jsoneditor to 9.5.6 or later.

## Is CVE-2021-3822 being exploited?

There is no known exploitation of CVE-2021-3822 in the wild and no public exploit code.

## Other vulnerabilities in josdejong/jsoneditor

- [CVE-2020-23849](https://insights.sbomify.com/CVE-2020-23849/): Cross-site Scripting in jsoneditor (medium 6.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-3822 and fix it if it is affected.

What it is: CVE-2021-3822 is a medium-severity denial of service vulnerability in josdejong/jsoneditor, published on 27 Sep 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-3822 in the wild and no public exploit code.

Affected packages and fixed versions:
- jsoneditor (npm): affected all versions; fixed in 9.5.6
- jsoneditor (npm): affected all versions; fixed in 9.5.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-3822/ (Markdown: https://insights.sbomify.com/CVE-2021-3822/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-3822
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-3822
- OSV: https://osv.dev/vulnerability/CVE-2021-3822

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-3822/
Summaries are generated and may contain mistakes; the official description above is the record.
