# CVE-2021-38266: Liferay Portal and Liferay DXP fails to properly import users from LDAP

> Remote attackers can prevent legitimate users from authenticating by exploiting an LDAP import flaw in Liferay Portal.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 2 Mar 2022
- **Updated:** 9 Jul 2026
- **Also known as:** BIT-liferay-2021-38266, GHSA-jp3m-vh3g-6ggp

## What is CVE-2021-38266?

CVE-2021-38266 is a high-severity denial of service vulnerability in Liferay Digital Experience Platform, published on 2 Mar 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The Portal Security module in Liferay Portal 7.2.1 and earlier, and Liferay DXP 7.0 before fix pack 90, 7.1 before fix pack 17 and 7.2 before fix pack 5 does not correctly import users from LDAP, which allows remote attackers to prevent a legitimate user from authenticating by attempting to sign in as a user that exist in LDAP.

## Which versions are affected by CVE-2021-38266?

5 open source packages ship an affected version, including com.liferay.portal:release.dxp.bom, liferay and com.liferay:com.liferay.portal.security.ldap.impl. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `com.liferay.portal:release.dxp.bom` | Maven | All versions | 7.3.0-ga1 |
| `com.liferay.portal:release.dxp.bom` | Maven | All versions | 7.3.0-ga1 |
| `liferay` | Bitnami | From 7.0.0 to 7.0.0 | None |
| `com.liferay:com.liferay.portal.security.ldap.impl` | Maven | All versions | 2.0.19 |
| `com.liferay:com.liferay.portal.security.ldap.impl` | Maven | All versions | 2.0.19 |

Products: Liferay Digital Experience Platform, Liferay Liferay Portal.

## How do I fix CVE-2021-38266?

Upgrade com.liferay.portal:release.dxp.bom to 7.3.0-ga1 or later.

## Is CVE-2021-38266 being exploited?

There is no known exploitation of CVE-2021-38266 in the wild and no public exploit code.

## Other vulnerabilities in Liferay Digital Experience Platform

- [CVE-2024-8980](https://insights.sbomify.com/CVE-2024-8980/): Liferay Portal and Liferay DXP Vulnerable to CSRF in the Script Console (critical 9.6)
- [CVE-2023-42496](https://insights.sbomify.com/CVE-2023-42496/): Liferay Portal and Liferay DXP vulnerable to reflected Cross-site Scripting (critical 9.6)
- [CVE-2023-42498](https://insights.sbomify.com/CVE-2023-42498/): Liferay Portal Language Override edit screen and Liferay DXP vulnerable to reflected Cross-site Scripting (critical 9.6)
- [CVE-2024-25147](https://insights.sbomify.com/CVE-2024-25147/): Liferay Portal and Liferay DXP vulnerable to Cross-site Scripting (critical 9.6)
- [CVE-2024-26269](https://insights.sbomify.com/CVE-2024-26269/): Liferay Portal Frontend JS module's portlet.js and Liferay DXP vulnerable to Cross-site Scripting (critical 9.6)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-38266 and fix it if it is affected.

What it is: CVE-2021-38266 is a high-severity denial of service vulnerability in Liferay Digital Experience Platform, published on 2 Mar 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-38266 in the wild and no public exploit code.

Affected packages and fixed versions:
- com.liferay.portal:release.dxp.bom (Maven): affected all versions; fixed in 7.3.0-ga1
- com.liferay.portal:release.dxp.bom (Maven): affected all versions; fixed in 7.3.0-ga1
- liferay (Bitnami): affected from 7.0.0 up to 7.0.0; no fix listed
- com.liferay:com.liferay.portal.security.ldap.impl (Maven): affected all versions; fixed in 2.0.19
- com.liferay:com.liferay.portal.security.ldap.impl (Maven): affected all versions; fixed in 2.0.19

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-38266/ (Markdown: https://insights.sbomify.com/CVE-2021-38266/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-38266
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-38266
- OSV: https://osv.dev/vulnerability/CVE-2021-38266

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-38266/
Summaries are generated and may contain mistakes; the official description above is the record.
