# CVE-2021-3828: Inefficient Regular Expression Complexity in nltk/nltk

> Attackers can cause denial of service in the nltk library by submitting inputs that trigger inefficient regular expression complexity.

- **Severity:** High 7.5 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 27 Sep 2021
- **Updated:** 3 Aug 2024
- **Also known as:** DEBIAN-CVE-2021-3828, GHSA-2ww3-fxvq-293j, MGASA-2023-0302, PYSEC-2021-356, UBUNTU-CVE-2021-3828, USN-5215-1, openSUSE-SU-2024:11958-1, openSUSE-SU-2025:15099-1

## What is CVE-2021-3828?

CVE-2021-3828 is a high-severity denial of service vulnerability in nltk/nltk, published on 27 Sep 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

nltk is vulnerable to Inefficient Regular Expression Complexity

Weakness: CWE-697 (Incorrect Comparison), CWE-1333 (Inefficient Regular Expression Complexity)

## Which versions are affected by CVE-2021-3828?

3 open source packages ship an affected version, including nltk. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `nltk` | PyPI | All versions | 3.6.4 |
| `nltk` | PyPI | All versions | 3.6.4 |
| `nltk` | PyPI | All versions | 3.6.4 |
| `python-nltk` | openSUSE:Tumbleweed | All versions | 3.7-1.1 |
| `python-nltk` | openSUSE:Tumbleweed | All versions | 3.9.1-2.4 |

Products: Nltk Nltk.

## How do I fix CVE-2021-3828?

Upgrade nltk to 3.6.4 or later.

## Is CVE-2021-3828 being exploited?

There is no known exploitation of CVE-2021-3828 in the wild and no public exploit code.

## Other vulnerabilities in nltk/nltk

- [CVE-2026-0848](https://insights.sbomify.com/CVE-2026-0848/): Arbitrary Code Execution in NLTK StanfordSegmenter via Untrusted JAR Loading (critical 10.0)
- [CVE-2025-14009](https://insights.sbomify.com/CVE-2025-14009/): Zip Slip Vulnerability in nltk/nltk Leading to Remote Code Execution (critical 10.0)
- [CVE-2026-78683](https://insights.sbomify.com/CVE-2026-78683/): NLTK before 3.10.0 Remote Code Execution via Unsafe Pickle Deserialization (critical 9.4)
- [CVE-2026-79657](https://insights.sbomify.com/CVE-2026-79657/): NLTK before 3.10.3 Remote Code Execution via Unsafe Pickle Deserialization (critical 9.3)
- [CVE-2026-79675](https://insights.sbomify.com/CVE-2026-79675/): NLTK before 3.10.3 JVM Argument Injection via Per-Call Options (critical 9.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-3828 and fix it if it is affected.

What it is: CVE-2021-3828 is a high-severity denial of service vulnerability in nltk/nltk, published on 27 Sep 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-3828 in the wild and no public exploit code.

Affected packages and fixed versions:
- nltk (PyPI): affected all versions; fixed in 3.6.4
- nltk (PyPI): affected all versions; fixed in 3.6.4
- nltk (PyPI): affected all versions; fixed in 3.6.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-3828/ (Markdown: https://insights.sbomify.com/CVE-2021-3828/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-3828
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-3828
- OSV: https://osv.dev/vulnerability/CVE-2021-3828

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-3828/
Summaries are generated and may contain mistakes; the official description above is the record.
