# CVE-2021-38294: Shell Command Injection Vulnerability in Nimbus Thrift Server

> Attackers can execute arbitrary code on Apache Storm Nimbus servers via crafted Thrift requests without authentication.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 25 Oct 2021
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-6768-mcjc-8223

## What is CVE-2021-38294?

CVE-2021-38294 is a critical command injection vulnerability in Apache Storm, published on 25 Oct 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

A Command Injection vulnerability exists in the getTopologyHistory service of the Apache Storm 2.x prior to 2.2.1 and Apache Storm 1.x prior to 1.2.4. A specially crafted thrift request to the Nimbus server allows Remote Code Execution (RCE) prior to authentication.

Weakness: CWE-78 (Improper Neutralization of Special Elements used in an OS Command), CWE-74 (Improper Neutralization of Special Elements in Output Used by a Downstream Component)

## Which versions are affected by CVE-2021-38294?

6 open source packages ship an affected version, including org.apache.storm:storm. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.storm:storm` | Maven | From 1.0.0 | 1.2.4 |
| `org.apache.storm:storm` | Maven | From 1.0.0 | 1.2.4 |
| `org.apache.storm:storm` | Maven | From 2.0.0 | 2.1.1 |
| `org.apache.storm:storm` | Maven | From 2.0.0 | 2.1.1 |
| `org.apache.storm:storm` | Maven | From 2.2.0 | 2.2.1 |
| `org.apache.storm:storm` | Maven | From 2.2.0 | 2.2.1 |

Products: Apache Storm.

## How do I fix CVE-2021-38294?

Upgrade org.apache.storm:storm to a fixed version for your release line: 1.2.4, 2.1.1 or 2.2.1.

## Is CVE-2021-38294 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2021-38294 exists.

Public exploit code:

- Apache Storm Nimbus getTopologyHistory Unauthenticated Command Execution (metasploit)

## Other vulnerabilities in Apache Storm

- [CVE-2021-40865](https://insights.sbomify.com/CVE-2021-40865/): Unsafe Pre-Authentication Deserialization In Workers (critical 9.8)
- [CVE-2018-11779](https://insights.sbomify.com/CVE-2018-11779/): Deserialization of Untrusted Data in Apache Storm (critical 9.8)
- [CVE-2015-3188](https://insights.sbomify.com/CVE-2015-3188/): Apache Storm remote code execution vulnerability (critical 9.8)
- [CVE-2026-35337](https://insights.sbomify.com/CVE-2026-35337/): Apache Storm Client: RCE through Unsafe Deserialization via Kerberos TGT Credential Handling (high 8.8)
- [CVE-2018-1331](https://insights.sbomify.com/CVE-2018-1331/): Code execution in org.apache.storm:storm-core (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-38294 and fix it if it is affected.

What it is: CVE-2021-38294 is a critical command injection vulnerability in Apache Storm, published on 25 Oct 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2021-38294 exists.

Affected packages and fixed versions:
- org.apache.storm:storm (Maven): affected from 1.0.0; fixed in 1.2.4
- org.apache.storm:storm (Maven): affected from 1.0.0; fixed in 1.2.4
- org.apache.storm:storm (Maven): affected from 2.0.0; fixed in 2.1.1
- org.apache.storm:storm (Maven): affected from 2.0.0; fixed in 2.1.1
- org.apache.storm:storm (Maven): affected from 2.2.0; fixed in 2.2.1
- org.apache.storm:storm (Maven): affected from 2.2.0; fixed in 2.2.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-38294/ (Markdown: https://insights.sbomify.com/CVE-2021-38294/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-38294
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-38294
- OSV: https://osv.dev/vulnerability/CVE-2021-38294

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-38294/
Summaries are generated and may contain mistakes; the official description above is the record.
