# CVE-2021-38296: Apache Spark Key Negotiation Vulnerability

> Attackers can recover encryption keys to decrypt RPC traffic offline if specific authentication features are enabled.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 10 Mar 2022
- **Updated:** 4 Aug 2024
- **Also known as:** BIT-spark-2021-38296, GHSA-9rr6-jpg7-9jg6, OESA-2022-1591, PYSEC-2022-186

## What is CVE-2021-38296?

CVE-2021-38296 is a high-severity vulnerability in Apache Spark, published on 10 Mar 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Apache Spark supports end-to-end encryption of RPC connections via "spark.authenticate" and "spark.network.crypto.enabled". In versions 3.1.2 and earlier, it uses a bespoke mutual authentication protocol that allows for full encryption key recovery. After an initial interactive attack, this would allow someone to decrypt plaintext traffic offline. Note that this does not affect security mechanisms controlled by "spark.authenticate.enableSaslEncryption", "spark.io.encryption.enabled", "spark.ssl", "spark.ui.strictTransportSecurity". Update to Apache Spark 3.1.3 or later

Weakness: CWE-294 (Authentication Bypass by Capture-replay)

## Which versions are affected by CVE-2021-38296?

6 open source packages ship an affected version, including org.apache.spark:spark-core, spark and pyspark. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.spark:spark-core` | Maven | All versions | 3.1.3 |
| `org.apache.spark:spark-core` | Maven | All versions | 3.1.3 |
| `spark` | Bitnami | All versions | 3.1.3 |
| `pyspark` | PyPI | All versions | 3.1.3 |
| `pyspark` | PyPI | All versions | 3.1.3 |
| `pyspark` | PyPI | All versions | 3.1.3 |

Products: Apache Spark, Oracle Financial Services Crime and Compliance Management Studio.

## How do I fix CVE-2021-38296?

Upgrade org.apache.spark:spark-core to 3.1.3 or later.

## Is CVE-2021-38296 being exploited?

There is no known exploitation of CVE-2021-38296 in the wild and no public exploit code.

## Other vulnerabilities in Apache Spark

- [CVE-2022-33891](https://insights.sbomify.com/CVE-2022-33891/): Apache Spark Command Injection (high 8.8, exploited in the wild)
- [CVE-2020-9480](https://insights.sbomify.com/CVE-2020-9480/): Improper Authentication in Apache Spark (critical 9.8)
- [CVE-2018-17190](https://insights.sbomify.com/CVE-2018-17190/): Remote Code Execution in spark-core (critical 9.8)
- [CVE-2019-20445](https://insights.sbomify.com/CVE-2019-20445/): HTTP Request Smuggling in Netty (critical 9.1)
- [CVE-2025-54920](https://insights.sbomify.com/CVE-2025-54920/): Apache Spark: Spark History Server Code Execution Vulnerability (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-38296 and fix it if it is affected.

What it is: CVE-2021-38296 is a high-severity vulnerability in Apache Spark, published on 10 Mar 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-38296 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.spark:spark-core (Maven): affected all versions; fixed in 3.1.3
- org.apache.spark:spark-core (Maven): affected all versions; fixed in 3.1.3
- spark (Bitnami): affected all versions; fixed in 3.1.3
- pyspark (PyPI): affected all versions; fixed in 3.1.3
- pyspark (PyPI): affected all versions; fixed in 3.1.3
- pyspark (PyPI): affected all versions; fixed in 3.1.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-38296/ (Markdown: https://insights.sbomify.com/CVE-2021-38296/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-38296
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-38296
- OSV: https://osv.dev/vulnerability/CVE-2021-38296

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-38296/
Summaries are generated and may contain mistakes; the official description above is the record.
