{"answers":{"affected":"3 open source packages ship an affected version, including yamale. It affects 1 product.","exploited":"There is no known exploitation of CVE-2021-38305 in the wild and no public exploit code.","fix":"Upgrade yamale to 3.0.8 or later.","what":"CVE-2021-38305 is a high-severity code injection vulnerability in n/a, published on 9 Aug 2021. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2021-38305 and fix it if it is affected.\n\nWhat it is: CVE-2021-38305 is a high-severity code injection vulnerability in n/a, published on 9 Aug 2021. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2021-38305 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- yamale (PyPI): affected all versions; fixed in 3.0.8\n- yamale (PyPI): affected all versions; fixed in 3.0.8\n- yamale (PyPI): affected all versions; fixed in 3.0.8\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2021-38305/ (Markdown: https://insights.sbomify.com/CVE-2021-38305/index.md)","id":"CVE-2021-38305","markdown":"https://insights.sbomify.com/CVE-2021-38305/index.md","name":"CVE-2021-38305","record":{"aliases":["GHSA-435p-f82x-mxwm","PYSEC-2021-119"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"Python schema validator","requires_auth":"none","summary":"Remote attackers can execute arbitrary code via crafted schema files due to unsafe eval usage in the Yamale library.","user_interaction":"required","vuln_class":"code_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"yamale","vendor":"23andme"}],"cvss":{"score":7.8,"severity":"high","source":"nvd","vector":"CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-434","name":"Unrestricted Upload of File with Dangerous Type"}],"description":"23andMe Yamale before 3.0.8 allows remote attackers to execute arbitrary code via a crafted schema file. The schema parser uses eval as part of its processing, and tries to protect from malicious expressions by limiting the builtins that are passed to the eval. When processing the schema, each line is run through Python's eval function to make the validator available. A well-constructed string within the schema rules can execute system commands; thus, by exploiting the vulnerability, an attacker can run arbitrary code on the image that invokes Yamale.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Command injection in Yamale","id":"CVE-2021-38305","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"code_injection","year":"2021"},"n_packages":3,"n_references":2,"next":{"headline":"Command injection in n/a","id":"CVE-2021-38306"},"packages":[{"ecosystem":"PyPI","fixed":["3.0.8"],"introduced":["0"],"last_affected":[],"package":"yamale","purl":null,"source":"GHSA-435p-f82x-mxwm"},{"ecosystem":"PyPI","fixed":["3.0.8"],"introduced":["0"],"last_affected":[],"package":"yamale","purl":"pkg:pypi/yamale","source":"GHSA-435p-f82x-mxwm"},{"ecosystem":"PyPI","fixed":["3.0.8"],"introduced":["0"],"last_affected":[],"package":"yamale","purl":"pkg:pypi/yamale","source":"PYSEC-2021-119"}],"prev":{"headline":"Privilege escalation in n/a","id":"CVE-2021-38304"},"products":["n/a"],"published":"2021-08-09","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-04","vendors":["n/a"]},"summary":"Remote attackers can execute arbitrary code via crafted schema files due to unsafe eval usage in the Yamale library.","url":"https://insights.sbomify.com/CVE-2021-38305/"}