# CVE-2021-38305: Command injection in Yamale

> Remote attackers can execute arbitrary code via crafted schema files due to unsafe eval usage in the Yamale library.

- **Severity:** High 7.8 (`CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 9 Aug 2021
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-435p-f82x-mxwm, PYSEC-2021-119

## What is CVE-2021-38305?

CVE-2021-38305 is a high-severity code injection vulnerability in n/a, published on 9 Aug 2021. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

23andMe Yamale before 3.0.8 allows remote attackers to execute arbitrary code via a crafted schema file. The schema parser uses eval as part of its processing, and tries to protect from malicious expressions by limiting the builtins that are passed to the eval. When processing the schema, each line is run through Python's eval function to make the validator available. A well-constructed string within the schema rules can execute system commands; thus, by exploiting the vulnerability, an attacker can run arbitrary code on the image that invokes Yamale.

Weakness: CWE-434 (Unrestricted Upload of File with Dangerous Type)

## Which versions are affected by CVE-2021-38305?

3 open source packages ship an affected version, including yamale. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `yamale` | PyPI | All versions | 3.0.8 |
| `yamale` | PyPI | All versions | 3.0.8 |
| `yamale` | PyPI | All versions | 3.0.8 |

Products: 23andme Yamale.

## How do I fix CVE-2021-38305?

Upgrade yamale to 3.0.8 or later.

## Is CVE-2021-38305 being exploited?

There is no known exploitation of CVE-2021-38305 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-38305 and fix it if it is affected.

What it is: CVE-2021-38305 is a high-severity code injection vulnerability in n/a, published on 9 Aug 2021. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2021-38305 in the wild and no public exploit code.

Affected packages and fixed versions:
- yamale (PyPI): affected all versions; fixed in 3.0.8
- yamale (PyPI): affected all versions; fixed in 3.0.8
- yamale (PyPI): affected all versions; fixed in 3.0.8

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-38305/ (Markdown: https://insights.sbomify.com/CVE-2021-38305/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-38305
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-38305
- OSV: https://osv.dev/vulnerability/CVE-2021-38305

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-38305/
Summaries are generated and may contain mistakes; the official description above is the record.
