CVE-2021-38345 Brizy <= 1.0.125 and 1.0.127 – 2.3.11 Incorrect authorization checks allowing Post modification
Any logged-in user can modify content of posts or pages created with the Brizy editor due to incorrect authorization checks.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- None listed
What is CVE-2021-38345?
CVE-2021-38345 is a high-severity missing authorization vulnerability in Brizy.io Brizy - Page Builder, published on 14 Oct 2021. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
The Brizy Page Builder plugin <= 2.3.11 for WordPress used an incorrect authorization check that allowed any logged-in user accessing any endpoint in the wp-admin directory to modify the content of any existing post or page created with the Brizy editor. An identical issue was found by another researcher in Brizy <= 1.0.125 and fixed in version 1.0.126, but the vulnerability was reintroduced in version 1.0.127.
Which versions are affected by CVE-2021-38345?
It affects 1 product.
Products include Brizy Brizy-Page Builder.
How do I fix CVE-2021-38345?
No fix has been published for CVE-2021-38345 yet. Limit exposure of the affected software until one is available.
Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.
Is CVE-2021-38345 being exploited?
There is no known exploitation of CVE-2021-38345 in the wild and no public exploit code.
Other vulnerabilities in Brizy.io Brizy - Page Builder
Sources
Also known as GHSA-mg85-w8wc-5fvp.