# CVE-2021-38345: Brizy <= 1.0.125 and 1.0.127 – 2.3.11 Incorrect authorization checks allowing Post modification

> Any logged-in user can modify content of posts or pages created with the Brizy editor due to incorrect authorization checks.

- **Severity:** High 7.1 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 14 Oct 2021
- **Updated:** 14 Feb 2025
- **Also known as:** GHSA-mg85-w8wc-5fvp

## What is CVE-2021-38345?

CVE-2021-38345 is a high-severity missing authorization vulnerability in Brizy.io Brizy - Page Builder, published on 14 Oct 2021. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

The Brizy Page Builder plugin <= 2.3.11 for WordPress used an incorrect authorization check that allowed any logged-in user accessing any endpoint in the wp-admin directory to modify the content of any existing post or page created with the Brizy editor. An identical issue was found by another researcher in Brizy <= 1.0.125 and fixed in version 1.0.126, but the vulnerability was reintroduced in version 1.0.127.

Weakness: CWE-863 (Incorrect Authorization), CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2021-38345?

It affects 1 product.


Products: Brizy Brizy-Page Builder.

## How do I fix CVE-2021-38345?

No fix has been published for CVE-2021-38345 yet. Limit exposure of the affected software until one is available.

## Is CVE-2021-38345 being exploited?

There is no known exploitation of CVE-2021-38345 in the wild and no public exploit code.

## Other vulnerabilities in Brizy.io Brizy - Page Builder

- [CVE-2021-38346](https://insights.sbomify.com/CVE-2021-38346/): Brizy <= 2.3.11 Authenticated Unrestricted File Upload and Path Traversal (high 8.8)
- [CVE-2021-38344](https://insights.sbomify.com/CVE-2021-38344/): Brizy <= 2.3.11 Authenticated Stored Cross-Site Scripting (medium 6.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-38345 and fix it if it is affected.

What it is: CVE-2021-38345 is a high-severity missing authorization vulnerability in Brizy.io Brizy - Page Builder, published on 14 Oct 2021. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-38345 in the wild and no public exploit code.

Affected product: Brizy.io Brizy - Page Builder. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-38345/ (Markdown: https://insights.sbomify.com/CVE-2021-38345/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-38345
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-38345
- OSV: https://osv.dev/vulnerability/CVE-2021-38345

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-38345/
Summaries are generated and may contain mistakes; the official description above is the record.
