{"answers":{"affected":"3 open source packages ship an affected version, including antilles-tools. It affects 1 product.","exploited":"There is no known exploitation of CVE-2021-3840 in the wild and no public exploit code.","fix":"Upgrade antilles-tools to 1.0.1 or later.","what":"CVE-2021-3840 is a high-severity vulnerability in Antilles, published on 12 Nov 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2021-3840 and fix it if it is affected.\n\nWhat it is: CVE-2021-3840 is a high-severity vulnerability in Antilles, published on 12 Nov 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2021-3840 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- antilles-tools (PyPI): affected all versions; fixed in 1.0.1\n- antilles-tools (PyPI): affected all versions; fixed in 1.0.1\n- antilles-tools (PyPI): affected all versions; fixed in 1.0.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2021-3840/ (Markdown: https://insights.sbomify.com/CVE-2021-3840/index.md)","id":"CVE-2021-3840","markdown":"https://insights.sbomify.com/CVE-2021-3840/index.md","name":"CVE-2021-3840","record":{"aliases":["GHSA-hgc3-hp6x-wpgx","PYSEC-2021-840"],"analysis":{"component_type":"library","fix_type":"patch","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Python library","requires_auth":"none","summary":"Attackers can execute remote code during installation by publishing malicious packages with names matching private dependencies to public repositories.","user_interaction":"required","vuln_class":"supply_chain"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"lenovo","cpe":[{"product":"antilles","vendor":"lenovo"}],"cvss":{"score":8.8,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-427","name":"Uncontrolled Search Path Element"}],"description":"A dependency confusion vulnerability was reported in the Antilles open-source software prior to version 1.0.1 that could allow for remote code execution during installation due to a package listed in requirements.txt not existing in the public package index (PyPi). MITRE classifies this weakness as an Uncontrolled Search Path Element (CWE-427) in which a private package dependency may be replaced by an unauthorized package of the same name published to a well-known public repository such as PyPi. The configuration has been updated to only install components built by Antilles, removing all other public package indexes. Additionally, the antilles-tools dependency has been published to PyPi.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Antilles Dependency Confusion Vulnerability","id":"CVE-2021-3840","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"supply_chain","year":"2021"},"n_packages":3,"n_references":1,"next":{"headline":"Stored Cross-site Scripting (XSS) in sylius/sylius","id":"CVE-2021-3841"},"packages":[{"ecosystem":"PyPI","fixed":["1.0.1"],"introduced":["0"],"last_affected":[],"package":"antilles-tools","purl":null,"source":"GHSA-hgc3-hp6x-wpgx"},{"ecosystem":"PyPI","fixed":["1.0.1"],"introduced":["0"],"last_affected":[],"package":"antilles-tools","purl":"pkg:pypi/antilles-tools","source":"GHSA-hgc3-hp6x-wpgx"},{"ecosystem":"PyPI","fixed":["1.0.1"],"introduced":["0"],"last_affected":[],"package":"antilles-tools","purl":"pkg:pypi/antilles-tools","source":"PYSEC-2021-840"}],"prev":{"headline":"Memory corruption in dpdk","id":"CVE-2021-3839"},"products":["Antilles"],"published":"2021-11-12","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-03","vendors":["Antilles"]},"summary":"Attackers can execute remote code during installation by publishing malicious packages with names matching private dependencies to public repositories.","url":"https://insights.sbomify.com/CVE-2021-3840/"}