CVE-2021-3841 Stored Cross-site Scripting (XSS) in sylius/sylius

Medium 4.1 Published Updated

Attackers can inject malicious scripts via SVG files in Sylius, leading to code execution in user browsers.

Exploited in the wild
Not known
Login needed
An administrator
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2021-3841?

CVE-2021-3841 is a medium-severity cross-site scripting vulnerability in sylius/sylius, published on 15 Nov 2024. An attacker needs administrator access to exploit it, with no action from the victim.

Official description

sylius/sylius versions prior to 1.9.10, 1.10.11, and 1.11.2 are vulnerable to stored cross-site scripting (XSS) through SVG files. This vulnerability allows attackers to inject malicious scripts that can be executed in the context of the user's browser.

Weakness: CWE-79

Which versions are affected by CVE-2021-3841?

6 open source packages ship an affected version, including sylius/sylius. It affects 1 product.

PackageAffectedFixed in
sylius/sylius PackagistAll versions1.9.10
sylius/sylius PackagistAll versions1.9.10
sylius/sylius PackagistFrom 1.10.01.10.11
sylius/sylius PackagistFrom 1.10.01.10.11
sylius/sylius PackagistFrom 1.11.01.11.2
sylius/sylius PackagistFrom 1.11.01.11.2

Products include Sylius Sylius.

How do I fix CVE-2021-3841?

Upgrade sylius/sylius to a fixed version for your release line: 1.9.10, 1.10.11 or 1.11.2.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2021-3841 being exploited?

There is no known exploitation of CVE-2021-3841 in the wild and no public exploit code.

Sources

Also known as GHSA-hhvr-2q69-4563.

Is CVE-2021-3841 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free