{"answers":{"affected":"2 open source packages ship an affected version, including grumpydictator/firefly-iii. It affects 1 product.","exploited":"There is no known exploitation of CVE-2021-3846 in the wild and no public exploit code.","fix":"Upgrade grumpydictator/firefly-iii to 5.6.2 or later.","what":"CVE-2021-3846 is a medium-severity vulnerability in firefly-iii/firefly-iii, published on 19 Oct 2021. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2021-3846 and fix it if it is affected.\n\nWhat it is: CVE-2021-3846 is a medium-severity vulnerability in firefly-iii/firefly-iii, published on 19 Oct 2021. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2021-3846 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- grumpydictator/firefly-iii (Packagist): affected all versions; fixed in 5.6.2\n- grumpydictator/firefly-iii (Packagist): affected all versions; fixed in 5.6.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2021-3846/ (Markdown: https://insights.sbomify.com/CVE-2021-3846/index.md)","id":"CVE-2021-3846","markdown":"https://insights.sbomify.com/CVE-2021-3846/index.md","name":"CVE-2021-3846","record":{"aliases":["GHSA-5gq7-826w-8282"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"Firefly III","requires_auth":"high_privilege","summary":"Attackers can upload dangerous file types to Firefly III, potentially leading to remote code execution.","user_interaction":"required","vuln_class":"file_upload"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"@huntrdev","cpe":[{"product":"firefly_iii","vendor":"firefly-iii"}],"cvss":{"score":6.3,"severity":"medium","source":"cna","vector":"CVSS:3.0/AV:L/AC:H/PR:H/UI:R/S:U/C:H/I:H/A:H","version":"3.0"},"cwes":[{"id":"CWE-434","name":"Unrestricted Upload of File with Dangerous Type"}],"description":"firefly-iii is vulnerable to Unrestricted Upload of File with Dangerous Type","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Unrestricted Upload of File with Dangerous Type in firefly-iii/firefly-iii","id":"CVE-2021-3846","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"file_upload","year":"2021"},"n_packages":2,"n_references":2,"next":{"headline":"Privilege escalation in kernel","id":"CVE-2021-3847"},"packages":[{"ecosystem":"Packagist","fixed":["5.6.2"],"introduced":["0"],"last_affected":[],"package":"grumpydictator/firefly-iii","purl":null,"source":"GHSA-5gq7-826w-8282"},{"ecosystem":"Packagist","fixed":["5.6.2"],"introduced":["0"],"last_affected":[],"package":"grumpydictator/firefly-iii","purl":"pkg:composer/grumpydictator/firefly-iii","source":"GHSA-5gq7-826w-8282"}],"prev":{"headline":"External Control of File Name or Path in netristv/ws-scrcpy","id":"CVE-2021-3845"},"products":["firefly-iii/firefly-iii"],"published":"2021-10-19","related":[{"cvss_score":6.5,"headline":"Incorrect Authorization in firefly-iii/firefly-iii","id":"CVE-2023-0298","kev_date_added":null,"published":"2023-01-14"},{"cvss_score":6.5,"headline":"Cross-Site Request Forgery (CSRF) in firefly-iii/firefly-iii","id":"CVE-2021-3728","kev_date_added":null,"published":"2021-08-23"},{"cvss_score":6.5,"headline":"Cross-Site Request Forgery (CSRF) in firefly-iii/firefly-iii","id":"CVE-2021-3730","kev_date_added":null,"published":"2021-08-23"},{"cvss_score":6.1,"headline":"Firefly III allows webhooks HTML Injection.","id":"CVE-2024-22075","kev_date_added":null,"published":"2024-01-05"},{"cvss_score":6.1,"headline":"Cross-site scripting in n/a","id":"CVE-2019-14667","kev_date_added":null,"published":"2019-08-05"},{"cvss_score":5.4,"headline":"Insufficient Session Expiration in firefly-iii/firefly-iii","id":"CVE-2023-1788","kev_date_added":null,"published":"2023-04-05"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-03","vendors":["firefly-iii"]},"summary":"Attackers can upload dangerous file types to Firefly III, potentially leading to remote code execution.","url":"https://insights.sbomify.com/CVE-2021-3846/"}