CVE-2021-3850 Authentication Bypass by Primary Weakness in adodb/adodb
An authentication bypass vulnerability in the adodb library allows attackers to circumvent authentication mechanisms, potentially gaining unauthorized access.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2021-3850?
CVE-2021-3850 is a critical authentication bypass vulnerability in Debian Debian Linux, published on 25 Jan 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Authentication Bypass by Primary Weakness in GitHub repository adodb/adodb prior to 5.20.21.
Which versions are affected by CVE-2021-3850?
4 open source packages ship an affected version, including adodb/adodb-php. It affects 2 products.
| Package | Affected | Fixed in |
|---|---|---|
adodb/adodb-php Packagist | All versions | 5.20.21 |
adodb/adodb-php Packagist | All versions | 5.20.21 |
adodb/adodb-php Packagist | From 5.21.0 | 5.21.4 |
adodb/adodb-php Packagist | From 5.21.0 | 5.21.4 |
Products include Adodb Project Adodb, Debian Debian Linux.
How do I fix CVE-2021-3850?
Upgrade adodb/adodb-php to a fixed version for your release line: 5.20.21 or 5.21.4.
Upgrade, and rotate credentials and sessions that may have been exposed. More about Authentication bypass.
Is CVE-2021-3850 being exploited?
There is no known exploitation of CVE-2021-3850 in the wild and no public exploit code.
Other vulnerabilities in Debian Debian Linux
Sources
Also known as DEBIAN-CVE-2021-3850, DLA-2912-1, DSA-5101-1, GHSA-65mj-7c86-79jf, MGASA-2022-0056, UBUNTU-CVE-2021-3850.