{"answers":{"affected":"4 open source packages ship an affected version, including adodb/adodb-php. It affects 2 products.","exploited":"There is no known exploitation of CVE-2021-3850 in the wild and no public exploit code.","fix":"Upgrade adodb/adodb-php to a fixed version for your release line: 5.20.21 or 5.21.4.","what":"CVE-2021-3850 is a critical authentication bypass vulnerability in Debian Debian Linux, published on 25 Jan 2022. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2021-3850 and fix it if it is affected.\n\nWhat it is: CVE-2021-3850 is a critical authentication bypass vulnerability in Debian Debian Linux, published on 25 Jan 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2021-3850 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- adodb/adodb-php (Packagist): affected all versions; fixed in 5.20.21\n- adodb/adodb-php (Packagist): affected all versions; fixed in 5.20.21\n- adodb/adodb-php (Packagist): affected from 5.21.0; fixed in 5.21.4\n- adodb/adodb-php (Packagist): affected from 5.21.0; fixed in 5.21.4\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2021-3850/ (Markdown: https://insights.sbomify.com/CVE-2021-3850/index.md)","id":"CVE-2021-3850","markdown":"https://insights.sbomify.com/CVE-2021-3850/index.md","name":"CVE-2021-3850","record":{"aliases":["DEBIAN-CVE-2021-3850","DLA-2912-1","DSA-5101-1","GHSA-65mj-7c86-79jf","MGASA-2022-0056","UBUNTU-CVE-2021-3850"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"PHP database library","requires_auth":"none","summary":"An authentication bypass vulnerability in the adodb library allows attackers to circumvent authentication mechanisms, potentially gaining unauthorized access.","user_interaction":"not_required","vuln_class":"auth_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"@huntrdev","cpe":[{"product":"adodb","vendor":"adodb_project"},{"product":"debian_linux","vendor":"debian"}],"cvss":{"score":9.1,"severity":"critical","source":"cna","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N","version":"3.0"},"cwes":[{"id":"CWE-287","name":"Improper Authentication"},{"id":"CWE-305","name":"Authentication Bypass by Primary Weakness"}],"description":"Authentication Bypass by Primary Weakness in GitHub repository adodb/adodb prior to 5.20.21.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Authentication Bypass by Primary Weakness in adodb/adodb","id":"CVE-2021-3850","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":"debian:debian_linux","products":["debian:debian_linux"],"type":"auth_bypass","year":"2021"},"n_packages":4,"n_references":4,"next":{"headline":"Open Redirect in firefly-iii/firefly-iii","id":"CVE-2021-3851"},"packages":[{"ecosystem":"Packagist","fixed":["5.20.21"],"introduced":["0"],"last_affected":[],"package":"adodb/adodb-php","purl":null,"source":"GHSA-65mj-7c86-79jf"},{"ecosystem":"Packagist","fixed":["5.20.21"],"introduced":["0"],"last_affected":[],"package":"adodb/adodb-php","purl":"pkg:composer/adodb/adodb-php","source":"GHSA-65mj-7c86-79jf"},{"ecosystem":"Packagist","fixed":["5.21.4"],"introduced":["5.21.0"],"last_affected":[],"package":"adodb/adodb-php","purl":null,"source":"GHSA-65mj-7c86-79jf"},{"ecosystem":"Packagist","fixed":["5.21.4"],"introduced":["5.21.0"],"last_affected":[],"package":"adodb/adodb-php","purl":"pkg:composer/adodb/adodb-php","source":"GHSA-65mj-7c86-79jf"}],"prev":{"headline":"Auth bypass in Fan Power Controller2 (FPC2)","id":"CVE-2021-3849"},"products":["adodb/adodb"],"published":"2022-01-25","related":[{"cvss_score":9.8,"headline":"ADOdb Library SQL Injection","id":"CVE-2016-7405","kev_date_added":null,"published":"2016-10-03"},{"cvss_score":6.1,"headline":"ADOdb Cross-site scripting vulnerability in old test script","id":"CVE-2016-4855","kev_date_added":null,"published":"2017-05-12"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-03","vendors":["adodb"]},"summary":"An authentication bypass vulnerability in the adodb library allows attackers to circumvent authentication mechanisms, potentially gaining unauthorized access.","url":"https://insights.sbomify.com/CVE-2021-3850/"}