# CVE-2021-38511: Links in archive can create arbitrary directories

> Attackers can create arbitrary directories outside the intended extraction path by using symlinks in TAR archives, affecting Rust applications using the tar crate.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 10 Aug 2021
- **Updated:** 4 Aug 2024
- **Also known as:** DEBIAN-CVE-2021-38511, GHSA-62jx-8vmh-4mcw, RUSTSEC-2021-0080, UBUNTU-CVE-2021-38511

## What is CVE-2021-38511?

CVE-2021-38511 is a high-severity path traversal vulnerability in n/a, published on 10 Aug 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

An issue was discovered in the tar crate before 0.4.36 for Rust. When symlinks are present in a TAR archive, extraction can create arbitrary directories via .. traversal.

Weakness: CWE-59 (Improper Link Resolution Before File Access)

## Which versions are affected by CVE-2021-38511?

3 open source packages ship an affected version, including tar. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `tar` | crates.io | All versions | 0.4.36 |
| `tar` | crates.io | All versions | 0.4.36 |
| `tar` | crates.io | From 0.0.0-0 | 0.4.36 |

Products: Tar Project Tar.

## How do I fix CVE-2021-38511?

Upgrade tar to 0.4.36 or later.

## Is CVE-2021-38511 being exploited?

There is no known exploitation of CVE-2021-38511 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2018-20990](https://insights.sbomify.com/CVE-2018-20990/): Arbitrary file overwrite in tar-rs (high 7.5)
- [CVE-2026-33056](https://insights.sbomify.com/CVE-2026-33056/): tar-rs: unpack_in can chmod arbitrary directories by following symlinks (medium 5.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-38511 and fix it if it is affected.

What it is: CVE-2021-38511 is a high-severity path traversal vulnerability in n/a, published on 10 Aug 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-38511 in the wild and no public exploit code.

Affected packages and fixed versions:
- tar (crates.io): affected all versions; fixed in 0.4.36
- tar (crates.io): affected all versions; fixed in 0.4.36
- tar (crates.io): affected from 0.0.0-0; fixed in 0.4.36

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-38511/ (Markdown: https://insights.sbomify.com/CVE-2021-38511/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-38511
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-38511
- OSV: https://osv.dev/vulnerability/CVE-2021-38511

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-38511/
Summaries are generated and may contain mistakes; the official description above is the record.
