# CVE-2021-38540: Apache Airflow: Variable Import endpoint missed authentication check

> Unauthenticated attackers can modify Airflow variables via the import endpoint, leading to potential remote code execution, data modification, or denial of service.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 9 Sep 2021
- **Updated:** 4 Aug 2024
- **Also known as:** BIT-airflow-2021-38540, GHSA-h88f-r7cw-8fv3, PYSEC-2021-326

## What is CVE-2021-38540?

CVE-2021-38540 is a critical missing authorization vulnerability in Apache Airflow, published on 9 Sep 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The variable import endpoint was not protected by authentication in Airflow >=2.0.0, <2.1.3. This allowed unauthenticated users to hit that endpoint to add/modify Airflow variables used in DAGs, potentially resulting in a denial of service, information disclosure or remote code execution. This issue affects Apache Airflow >=2.0.0, <2.1.3.

Weakness: CWE-306 (Missing Authentication for Critical Functionality), CWE-269 (Improper Privilege Management)

## Which versions are affected by CVE-2021-38540?

4 open source packages ship an affected version, including apache-airflow and airflow. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `apache-airflow` | PyPI | From 2.0.0 | 2.1.3 |
| `apache-airflow` | PyPI | From 2.0.0 | 2.1.3 |
| `apache-airflow` | PyPI | From 2.0.0 | 2.1.3 |
| `airflow` | Bitnami | From 2.0.0 | 2.1.3 |

Products: Apache Airflow.

## How do I fix CVE-2021-38540?

Upgrade apache-airflow to 2.1.3 or later.

## Is CVE-2021-38540 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2021-38540 exists.

Public exploit code:

- Missing Authentication on Critical component CVE-2021-38540 (github_poc): https://github.com/Captain-v-hook/PoC-for-CVE-2021-38540-
- Apache Airflow - Unauthenticated Variable Import (nuclei): http/cves/2021/CVE-2021-38540.yaml

## Other vulnerabilities in Apache Airflow

- [CVE-2020-13927](https://insights.sbomify.com/CVE-2020-13927/): Apache Airflow's Experimental API Authentication Bypass (critical 9.8, exploited in the wild)
- [CVE-2020-11978](https://insights.sbomify.com/CVE-2020-11978/): Apache Airflow Command Injection (high 8.8, exploited in the wild)
- [CVE-2026-33264](https://insights.sbomify.com/CVE-2026-33264/): Apache Airflow: DAG author RCE on webserver via unrestricted import_string() in BaseSerialization.deserialize() (critical 9.8)
- [CVE-2023-25754](https://insights.sbomify.com/CVE-2023-25754/): Apache Airflow: Privilege escalation using airflow logs (critical 9.8)
- [CVE-2023-22884](https://insights.sbomify.com/CVE-2023-22884/): Apache Airflow, Apache Airflow MySQL Provider: Arbitrary file read via MySQL provider in Apache Airflow (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-38540 and fix it if it is affected.

What it is: CVE-2021-38540 is a critical missing authorization vulnerability in Apache Airflow, published on 9 Sep 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2021-38540 exists.

Affected packages and fixed versions:
- apache-airflow (PyPI): affected from 2.0.0; fixed in 2.1.3
- apache-airflow (PyPI): affected from 2.0.0; fixed in 2.1.3
- apache-airflow (PyPI): affected from 2.0.0; fixed in 2.1.3
- airflow (Bitnami): affected from 2.0.0; fixed in 2.1.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-38540/ (Markdown: https://insights.sbomify.com/CVE-2021-38540/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-38540
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-38540
- OSV: https://osv.dev/vulnerability/CVE-2021-38540

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-38540/
Summaries are generated and may contain mistakes; the official description above is the record.
