# CVE-2021-38598: OpenStack Neutron vulnerable to hardware address impersonation

> Attackers can impersonate hardware addresses in OpenStack Neutron using linuxbridge with ebtables-nft, causing denial of service or traffic interception.

- **Severity:** Critical 9.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 23 Aug 2021
- **Updated:** 4 Aug 2024
- **Also known as:** DEBIAN-CVE-2021-38598, GHSA-hvm4-mc7m-22w4, PYSEC-2021-360, UBUNTU-CVE-2021-38598

## What is CVE-2021-38598?

CVE-2021-38598 is a critical vulnerability in n/a, published on 23 Aug 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

OpenStack Neutron before 16.4.1, 17.x before 17.1.3, and 18.0.0 allows hardware address impersonation when the linuxbridge driver with ebtables-nft is used on a Netfilter-based platform. By sending carefully crafted packets, anyone in control of a server instance connected to the virtual switch can impersonate the hardware addresses of other systems on the network, resulting in denial of service or in some cases possibly interception of traffic intended for other destinations.

Weakness: CWE-290 (Authentication Bypass by Spoofing)

## Which versions are affected by CVE-2021-38598?

7 open source packages ship an affected version, including neutron. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `neutron` | PyPI | All versions | None |
| `neutron` | PyPI | All versions | None |
| `neutron` | PyPI | All versions | 16.4.1, 17.1.3, 18.1.0 |
| `neutron` | PyPI | All versions | 16.4.1 |
| `neutron` | PyPI | All versions | 16.4.1 |
| `neutron` | PyPI | From 17.0.0 | 17.1.3 |
| `neutron` | PyPI | From 17.0.0 | 17.1.3 |

Products: Openstack Neutron.

## How do I fix CVE-2021-38598?

Upgrade neutron to a fixed version for your release line: 16.4.1, 17.1.3 or 18.1.0.

## Is CVE-2021-38598 being exploited?

There is no known exploitation of CVE-2021-38598 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2015-8914](https://insights.sbomify.com/CVE-2015-8914/): OpenStack Neutron allows remote attackers to bypass an intended ICMPv6-spoofing protection mechanism (critical 9.1)
- [CVE-2016-5362](https://insights.sbomify.com/CVE-2016-5362/): OpenStack Neutron allows remote attackers to bypass an intended DHCP-spoofing protection mechanism (high 8.2)
- [CVE-2016-5363](https://insights.sbomify.com/CVE-2016-5363/): OpenStack Neutron Intended MAC-spoofing protection mechanism bypass (high 8.2)
- [CVE-2014-3632](https://insights.sbomify.com/CVE-2014-3632/): Privilege escalation in n/a (high 7.6)
- [CVE-2021-20267](https://insights.sbomify.com/CVE-2021-20267/): Openstack Neutron has Insufficient Verification of IPv6 addresses (high 7.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-38598 and fix it if it is affected.

What it is: CVE-2021-38598 is a critical vulnerability in n/a, published on 23 Aug 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-38598 in the wild and no public exploit code.

Affected packages and fixed versions:
- neutron (PyPI): affected all versions; no fix listed
- neutron (PyPI): affected all versions; no fix listed
- neutron (PyPI): affected all versions; fixed in 16.4.1, 17.1.3, 18.1.0
- neutron (PyPI): affected all versions; fixed in 16.4.1
- neutron (PyPI): affected all versions; fixed in 16.4.1
- neutron (PyPI): affected from 17.0.0; fixed in 17.1.3
- neutron (PyPI): affected from 17.0.0; fixed in 17.1.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-38598/ (Markdown: https://insights.sbomify.com/CVE-2021-38598/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-38598
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-38598
- OSV: https://osv.dev/vulnerability/CVE-2021-38598

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-38598/
Summaries are generated and may contain mistakes; the official description above is the record.
