{"answers":{"affected":"2 open source packages ship an affected version, including edu.stanford.nlp:stanford-corenlp. It affects 1 product.","exploited":"There is no known exploitation of CVE-2021-3869 in the wild and no public exploit code.","fix":"Upgrade edu.stanford.nlp:stanford-corenlp to 4.3.1 or later.","what":"CVE-2021-3869 is a high-severity vulnerability in stanfordnlp/corenlp, published on 19 Oct 2021. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2021-3869 and fix it if it is affected.\n\nWhat it is: CVE-2021-3869 is a high-severity vulnerability in stanfordnlp/corenlp, published on 19 Oct 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2021-3869 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- edu.stanford.nlp:stanford-corenlp (Maven): affected all versions; fixed in 4.3.1\n- edu.stanford.nlp:stanford-corenlp (Maven): affected all versions; fixed in 4.3.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2021-3869/ (Markdown: https://insights.sbomify.com/CVE-2021-3869/index.md)","id":"CVE-2021-3869","markdown":"https://insights.sbomify.com/CVE-2021-3869/index.md","name":"CVE-2021-3869","record":{"aliases":["GHSA-8gf7-w3cp-gfh3"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_read","denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Stanford CoreNLP library","requires_auth":"none","summary":"Attackers can exploit XML External Entity vulnerabilities in Stanford CoreNLP to read sensitive files or cause denial of service.","user_interaction":"not_required","vuln_class":"xxe"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"@huntrdev","cpe":[{"product":"corenlp","vendor":"stanford"}],"cvss":{"score":8.6,"severity":"high","source":"cna","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:L/A:L","version":"3.0"},"cwes":[{"id":"CWE-611","name":"Improper Restriction of XML External Entity Reference"}],"description":"corenlp is vulnerable to Improper Restriction of XML External Entity Reference","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Improper Restriction of XML External Entity Reference in stanfordnlp/corenlp","id":"CVE-2021-3869","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"xxe","year":"2021"},"n_packages":2,"n_references":2,"next":{"headline":"DO NOT USE THIS CANDIDATE NUMBER.","id":"CVE-2021-3870"},"packages":[{"ecosystem":"Maven","fixed":["4.3.1"],"introduced":["0"],"last_affected":[],"package":"edu.stanford.nlp:stanford-corenlp","purl":null,"source":"GHSA-8gf7-w3cp-gfh3"},{"ecosystem":"Maven","fixed":["4.3.1"],"introduced":["0"],"last_affected":[],"package":"edu.stanford.nlp:stanford-corenlp","purl":"pkg:maven/edu.stanford.nlp/stanford-corenlp","source":"GHSA-8gf7-w3cp-gfh3"}],"prev":{"headline":"DO NOT USE THIS CANDIDATE NUMBER.","id":"CVE-2021-3868"},"products":["stanfordnlp/corenlp"],"published":"2021-10-19","related":[{"cvss_score":9.8,"headline":"Access Control vulnerability within CoreNLP","id":"CVE-2021-44550","kev_date_added":null,"published":"2022-02-23"},{"cvss_score":9.8,"headline":"Improper Restriction of XML External Entity Reference in stanfordnlp/corenlp","id":"CVE-2021-3878","kev_date_added":null,"published":"2021-10-15"},{"cvss_score":6.1,"headline":"Improper Restriction of XML External Entity Reference in stanfordnlp/corenlp","id":"CVE-2022-0198","kev_date_added":null,"published":"2022-01-13"},{"cvss_score":4.7,"headline":"Improper Restriction of XML External Entity Reference in stanfordnlp/corenlp","id":"CVE-2022-0239","kev_date_added":null,"published":"2022-01-17"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-03","vendors":["stanfordnlp"]},"summary":"Attackers can exploit XML External Entity vulnerabilities in Stanford CoreNLP to read sensitive files or cause denial of service.","url":"https://insights.sbomify.com/CVE-2021-3869/"}