# CVE-2021-3869: Improper Restriction of XML External Entity Reference in stanfordnlp/corenlp

> Attackers can exploit XML External Entity vulnerabilities in Stanford CoreNLP to read sensitive files or cause denial of service.

- **Severity:** High 8.6 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 19 Oct 2021
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-8gf7-w3cp-gfh3

## What is CVE-2021-3869?

CVE-2021-3869 is a high-severity vulnerability in stanfordnlp/corenlp, published on 19 Oct 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

corenlp is vulnerable to Improper Restriction of XML External Entity Reference

Weakness: CWE-611 (Improper Restriction of XML External Entity Reference)

## Which versions are affected by CVE-2021-3869?

2 open source packages ship an affected version, including edu.stanford.nlp:stanford-corenlp. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `edu.stanford.nlp:stanford-corenlp` | Maven | All versions | 4.3.1 |
| `edu.stanford.nlp:stanford-corenlp` | Maven | All versions | 4.3.1 |

Products: Stanford Corenlp.

## How do I fix CVE-2021-3869?

Upgrade edu.stanford.nlp:stanford-corenlp to 4.3.1 or later.

## Is CVE-2021-3869 being exploited?

There is no known exploitation of CVE-2021-3869 in the wild and no public exploit code.

## Other vulnerabilities in stanfordnlp/corenlp

- [CVE-2021-44550](https://insights.sbomify.com/CVE-2021-44550/): Access Control vulnerability within CoreNLP (critical 9.8)
- [CVE-2021-3878](https://insights.sbomify.com/CVE-2021-3878/): Improper Restriction of XML External Entity Reference in stanfordnlp/corenlp (critical 9.8)
- [CVE-2022-0198](https://insights.sbomify.com/CVE-2022-0198/): Improper Restriction of XML External Entity Reference in stanfordnlp/corenlp (medium 6.1)
- [CVE-2022-0239](https://insights.sbomify.com/CVE-2022-0239/): Improper Restriction of XML External Entity Reference in stanfordnlp/corenlp (medium 4.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-3869 and fix it if it is affected.

What it is: CVE-2021-3869 is a high-severity vulnerability in stanfordnlp/corenlp, published on 19 Oct 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-3869 in the wild and no public exploit code.

Affected packages and fixed versions:
- edu.stanford.nlp:stanford-corenlp (Maven): affected all versions; fixed in 4.3.1
- edu.stanford.nlp:stanford-corenlp (Maven): affected all versions; fixed in 4.3.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-3869/ (Markdown: https://insights.sbomify.com/CVE-2021-3869/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-3869
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-3869
- OSV: https://osv.dev/vulnerability/CVE-2021-3869

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-3869/
Summaries are generated and may contain mistakes; the official description above is the record.
