# CVE-2021-3882: Sensitive Cookie in HTTPS Session Without 'Secure' Attribute in ledgersmb/ledgersmb

> Attackers can steal session cookies via HTTP traffic if the server is behind a reverse proxy without Secure attribute, leading to account takeover.

- **Severity:** Medium 5.9 (`CVSS:3.0/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 14 Oct 2021
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-q34c-v76q-8jx6, UBUNTU-CVE-2021-3882

## What is CVE-2021-3882?

CVE-2021-3882 is a medium-severity vulnerability in ledgersmb/ledgersmb, published on 14 Oct 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

LedgerSMB does not set the 'Secure' attribute on the session authorization cookie when the client uses HTTPS and the LedgerSMB server is behind a reverse proxy. By tricking a user to use an unencrypted connection (HTTP), an attacker may be able to obtain the authentication data by capturing network traffic. LedgerSMB 1.8 and newer switched from Basic authentication to using cookie authentication with encrypted cookies. Although an attacker can't access the information inside the cookie, nor the password of the user, possession of the cookie is enough to access the application as the user from which the cookie has been obtained. In order for the attacker to obtain the cookie, first of all the server must be configured to respond to unencrypted requests, the attacker must be suitably positioned to eavesdrop on the network traffic between the client and the server *and* the user must be tricked into using unencrypted HTTP traffic. Proper audit control and separation of duties limit Integrity impact of the attack vector. Users of LedgerSMB 1.8 are urged to upgrade to known-fixed versions. Users of LedgerSMB 1.7 or 1.9 are unaffected by this vulnerability and don't need to take action. As a workaround, users may configure their Apache or Nginx reverse proxy to add the Secure attribute at the network boundary instead of relying on LedgerSMB. For Apache, please refer to the 'Header always edit' configuration command in the mod_headers module. For Nginx, please refer to the 'proxy_cookie_flags' configuration command.

Weakness: CWE-311 (Missing Encryption of Sensitive Data), CWE-614 (Sensitive Cookie in HTTPS Session Without 'Secure' Attribute)

## Which versions are affected by CVE-2021-3882?

It affects 1 product.


Products: Ledgersmb Ledgersmb.

## How do I fix CVE-2021-3882?

Upgrade to a fixed version.

## Is CVE-2021-3882 being exploited?

There is no known exploitation of CVE-2021-3882 in the wild and no public exploit code.

## Other vulnerabilities in ledgersmb/ledgersmb

- [CVE-2007-3907](https://insights.sbomify.com/CVE-2007-3907/): Auth bypass in n/a (critical 10.0)
- [CVE-2007-1329](https://insights.sbomify.com/CVE-2007-1329/): Path traversal in n/a (critical 10.0)
- [CVE-2018-9246](https://insights.sbomify.com/CVE-2018-9246/): Command injection in n/a (critical 9.8)
- [CVE-2007-1437](https://insights.sbomify.com/CVE-2007-1437/): Auth bypass in n/a (critical 9.0)
- [CVE-2008-4077](https://insights.sbomify.com/CVE-2008-4077/): Denial of service in n/a (high 7.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-3882 and fix it if it is affected.

What it is: CVE-2021-3882 is a medium-severity vulnerability in ledgersmb/ledgersmb, published on 14 Oct 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2021-3882 in the wild and no public exploit code.

Affected product: ledgersmb/ledgersmb. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-3882/ (Markdown: https://insights.sbomify.com/CVE-2021-3882/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-3882
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-3882
- OSV: https://osv.dev/vulnerability/CVE-2021-3882

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-3882/
Summaries are generated and may contain mistakes; the official description above is the record.
