# CVE-2021-3908: Infinite certificate chain depth results in OctoRPKI running forever

> Attackers can cause OctoRPKI to hang indefinitely by providing an infinitely deep certificate chain, leading to a denial of service.

- **Severity:** Medium 5.9 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 11 Nov 2021
- **Updated:** 16 Sep 2024
- **Also known as:** DEBIAN-CVE-2021-3908, GHSA-g5gj-9ggf-9vmq, GO-2022-0249

## What is CVE-2021-3908?

CVE-2021-3908 is a medium-severity denial of service vulnerability in Debian Debian Linux, published on 11 Nov 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

OctoRPKI does not limit the depth of a certificate chain, allowing for a CA to create children in an ad-hoc fashion, thereby making tree traversal never end.

Weakness: CWE-835 (Loop with Unreachable Exit Condition), CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2021-3908?

3 open source packages ship an affected version, including github.com/cloudflare/cfrpki. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/cloudflare/cfrpki` | Go | All versions | 1.4.0 |
| `github.com/cloudflare/cfrpki` | Go | All versions | 1.4.0 |
| `github.com/cloudflare/cfrpki` | Go | All versions | 1.4.0 |

Products: Cloudflare Octorpki, Debian Debian Linux.

## How do I fix CVE-2021-3908?

Upgrade github.com/cloudflare/cfrpki to 1.4.0 or later.

## Is CVE-2021-3908 being exploited?

There is no known exploitation of CVE-2021-3908 in the wild and no public exploit code.

## Other vulnerabilities in Debian Debian Linux

- [CVE-2021-3978](https://insights.sbomify.com/CVE-2021-3978/): Improper Preservation of Permissions in github.com/cloudflare/cfrpki/cmd/octorpki (high 7.5)
- [CVE-2021-3761](https://insights.sbomify.com/CVE-2021-3761/): OctoRPKI lacks contextual out-of-bounds check when validating RPKI ROA maxLength values (high 7.5)
- [CVE-2021-3907](https://insights.sbomify.com/CVE-2021-3907/): Arbitrary filepath traversal via URI injection (high 7.4)
- [CVE-2022-3616](https://insights.sbomify.com/CVE-2022-3616/): OctoRPKI crash when maximum iterations number is reached (medium 5.4)
- [CVE-2021-3909](https://insights.sbomify.com/CVE-2021-3909/): Infinite open connection causes OctoRPKI to hang forever (medium 4.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-3908 and fix it if it is affected.

What it is: CVE-2021-3908 is a medium-severity denial of service vulnerability in Debian Debian Linux, published on 11 Nov 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-3908 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/cloudflare/cfrpki (Go): affected all versions; fixed in 1.4.0
- github.com/cloudflare/cfrpki (Go): affected all versions; fixed in 1.4.0
- github.com/cloudflare/cfrpki (Go): affected all versions; fixed in 1.4.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-3908/ (Markdown: https://insights.sbomify.com/CVE-2021-3908/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-3908
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-3908
- OSV: https://osv.dev/vulnerability/CVE-2021-3908

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-3908/
Summaries are generated and may contain mistakes; the official description above is the record.
