# CVE-2021-39109: Path traversal in atlasboard

> Remote attackers can read arbitrary files via path traversal in Atlassian Atlasboard, requiring an upgrade to secure the tool.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 1 Sep 2021
- **Updated:** 11 Oct 2024
- **Also known as:** GHSA-25pr-6pr6-68v7

## What is CVE-2021-39109?

CVE-2021-39109 is a high-severity path traversal vulnerability in Atlassian Atlasboard, published on 1 Sep 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The renderWidgetResource resource in Atlasian Atlasboard before version 1.1.9 allows remote attackers to read arbitrary files via a path traversal vulnerability.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2021-39109?

2 open source packages ship an affected version, including atlasboard. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `atlasboard` | npm | All versions | 1.1.9 |
| `atlasboard` | npm | All versions | 1.1.9 |

Products: Atlassian Atlasboard.

## How do I fix CVE-2021-39109?

Upgrade atlasboard to 1.1.9 or later.

## Is CVE-2021-39109 being exploited?

There is no known exploitation of CVE-2021-39109 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-39109 and fix it if it is affected.

What it is: CVE-2021-39109 is a high-severity path traversal vulnerability in Atlassian Atlasboard, published on 1 Sep 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-39109 in the wild and no public exploit code.

Affected packages and fixed versions:
- atlasboard (npm): affected all versions; fixed in 1.1.9
- atlasboard (npm): affected all versions; fixed in 1.1.9

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-39109/ (Markdown: https://insights.sbomify.com/CVE-2021-39109/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-39109
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-39109
- OSV: https://osv.dev/vulnerability/CVE-2021-39109

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-39109/
Summaries are generated and may contain mistakes; the official description above is the record.
