# CVE-2021-3911: Misconfigured IP address field in ROA leads to OctoRPKI crash

> Attackers can crash OctoRPKI by providing a Route Origin Authorization with an invalid IP address field, disrupting RPKI validation services.

- **Severity:** Medium 4.2 (`CVSS:3.1/AV:N/AC:H/PR:H/UI:R/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 11 Nov 2021
- **Updated:** 16 Sep 2024
- **Also known as:** DEBIAN-CVE-2021-3911, GHSA-w6ww-fmfx-2x22, GO-2022-0252

## What is CVE-2021-3911?

CVE-2021-3911 is a medium-severity denial of service vulnerability in Debian Debian Linux, published on 11 Nov 2021. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.

### Official description

If the ROA that a repository returns contains too many bits for the IP address then OctoRPKI will crash.

Weakness: CWE-252 (Unchecked Return Value), CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2021-3911?

3 open source packages ship an affected version, including github.com/cloudflare/cfrpki. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/cloudflare/cfrpki` | Go | All versions | 1.4.0 |
| `github.com/cloudflare/cfrpki` | Go | All versions | 1.4.0 |
| `github.com/cloudflare/cfrpki` | Go | All versions | 1.4.0 |

Products: Cloudflare Octorpki, Debian Debian Linux.

## How do I fix CVE-2021-3911?

Upgrade github.com/cloudflare/cfrpki to 1.4.0 or later.

## Is CVE-2021-3911 being exploited?

There is no known exploitation of CVE-2021-3911 in the wild and no public exploit code.

## Other vulnerabilities in Debian Debian Linux

- [CVE-2021-3978](https://insights.sbomify.com/CVE-2021-3978/): Improper Preservation of Permissions in github.com/cloudflare/cfrpki/cmd/octorpki (high 7.5)
- [CVE-2021-3761](https://insights.sbomify.com/CVE-2021-3761/): OctoRPKI lacks contextual out-of-bounds check when validating RPKI ROA maxLength values (high 7.5)
- [CVE-2021-3907](https://insights.sbomify.com/CVE-2021-3907/): Arbitrary filepath traversal via URI injection (high 7.4)
- [CVE-2021-3908](https://insights.sbomify.com/CVE-2021-3908/): Infinite certificate chain depth results in OctoRPKI running forever (medium 5.9)
- [CVE-2022-3616](https://insights.sbomify.com/CVE-2022-3616/): OctoRPKI crash when maximum iterations number is reached (medium 5.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-3911 and fix it if it is affected.

What it is: CVE-2021-3911 is a medium-severity denial of service vulnerability in Debian Debian Linux, published on 11 Nov 2021. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2021-3911 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/cloudflare/cfrpki (Go): affected all versions; fixed in 1.4.0
- github.com/cloudflare/cfrpki (Go): affected all versions; fixed in 1.4.0
- github.com/cloudflare/cfrpki (Go): affected all versions; fixed in 1.4.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-3911/ (Markdown: https://insights.sbomify.com/CVE-2021-3911/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-3911
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-3911
- OSV: https://osv.dev/vulnerability/CVE-2021-3911

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-3911/
Summaries are generated and may contain mistakes; the official description above is the record.
