CVE-2021-39131 Improper Handling of Unexpected Data Type in ced

High 7.5 Published Updated
Exploited in the wild
Not known
Fix
Available

What is CVE-2021-39131?

CVE-2021-39131 is a high-severity vulnerability in sonicdoe ced, published on 17 Aug 2021.

Official description

ced detects character encoding using Google’s compact_enc_det library. In ced v0.1.0, passing data types other than `Buffer` causes the Node.js process to crash. The problem has been patched in ced v1.0.0. As a workaround, before passing an argument to ced, verify it’s a `Buffer` using `Buffer.isBuffer(obj)`.

Weakness: CWE-755, CWE-241

Which versions are affected by CVE-2021-39131?

2 open source packages ship an affected version, including ced. It affects 1 product.

PackageAffectedFixed in
ced npmAll versions1.0.0
ced npmAll versions1.0.0

Products include Ced Project Ced.

How do I fix CVE-2021-39131?

Upgrade ced to 1.0.0 or later.

Is CVE-2021-39131 being exploited?

There is no known exploitation of CVE-2021-39131 in the wild and no public exploit code.

Sources

Also known as GHSA-27wq-qx3q-fxm9.

Is CVE-2021-39131 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free