# CVE-2021-39132: YAML deserialization can run untrusted code

> An authenticated user can execute arbitrary code on Rundeck servers by uploading crafted YAML files or plugins, requiring an upgrade to patched versions.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 30 Aug 2021
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-q4rf-3fhx-88pf

## What is CVE-2021-39132?

CVE-2021-39132 is a high-severity unsafe deserialization vulnerability in rundeck, published on 30 Aug 2021. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Rundeck is an open source automation service with a web console, command line tools and a WebAPI. Prior to version 3.3.14 and version 3.4.3, an authorized user can upload a zip-format plugin with a crafted plugin.yaml, or a crafted aclpolicy yaml file, or upload an untrusted project archive with a crafted aclpolicy yaml file, that can cause the server to run untrusted code on Rundeck Community or Enterprise Edition. An authenticated user can make a POST request, that can cause the server to run untrusted code on Rundeck Enterprise Edition. The zip-format plugin issues requires authentication and authorization to these access levels, and affects all Rundeck editions:`admin` level access to the `system` resource type. The ACL Policy yaml file upload issues requires authentication and authorization to these access levels, and affects all Rundeck editions: `create` `update` or `admin` level access to a `project_acl` resource, and/or`create` `update` or `admin` level access to the `system_acl` resource. The unauthorized POST request requires authentication, but no specific authorization, and affects Rundeck Enterprise only. Patches are available in versions 3.4.3, 3.3.14

Weakness: CWE-502 (Deserialization of Untrusted Data)

## Which versions are affected by CVE-2021-39132?

4 open source packages ship an affected version, including org.rundeck:rundeck-core. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.rundeck:rundeck-core` | Maven | All versions | 3.3.14 |
| `org.rundeck:rundeck-core` | Maven | All versions | 3.3.14 |
| `org.rundeck:rundeck-core` | Maven | From 3.4.0 | 3.4.3 |
| `org.rundeck:rundeck-core` | Maven | From 3.4.0 | 3.4.3 |

Products: Pagerduty Rundeck.

## How do I fix CVE-2021-39132?

Upgrade org.rundeck:rundeck-core to a fixed version for your release line: 3.3.14 or 3.4.3.

## Is CVE-2021-39132 being exploited?

There is no known exploitation of CVE-2021-39132 in the wild and no public exploit code.

## Other vulnerabilities in rundeck

- [CVE-2022-29186](https://insights.sbomify.com/CVE-2022-29186/): Use of Hard-coded Cryptographic Key in rundeck/rundeck, rundeckpro/enterprise (critical 9.1)
- [CVE-2023-48222](https://insights.sbomify.com/CVE-2023-48222/): Authenticated users can view or delete jobs they do not have authorization for in Rundeck (high 8.1)
- [CVE-2021-41112](https://insights.sbomify.com/CVE-2021-41112/): Missing Authorization in Rundeck (high 8.1)
- [CVE-2022-31044](https://insights.sbomify.com/CVE-2022-31044/): Plaintext Storage of Keys and Passwords in Rundeck and PagerDuty Process Automation (high 7.5)
- [CVE-2021-39133](https://insights.sbomify.com/CVE-2021-39133/): Cross-Site Request Forgery (CSRF) can run untrusted code on Rundeck server (high 7.2)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-39132 and fix it if it is affected.

What it is: CVE-2021-39132 is a high-severity unsafe deserialization vulnerability in rundeck, published on 30 Aug 2021. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-39132 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.rundeck:rundeck-core (Maven): affected all versions; fixed in 3.3.14
- org.rundeck:rundeck-core (Maven): affected all versions; fixed in 3.3.14
- org.rundeck:rundeck-core (Maven): affected from 3.4.0; fixed in 3.4.3
- org.rundeck:rundeck-core (Maven): affected from 3.4.0; fixed in 3.4.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-39132/ (Markdown: https://insights.sbomify.com/CVE-2021-39132/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-39132
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-39132
- OSV: https://osv.dev/vulnerability/CVE-2021-39132

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-39132/
Summaries are generated and may contain mistakes; the official description above is the record.
