# CVE-2021-39135: UNIX Symbolic Link (Symlink) Following in @npmcli/arborist

> Arborist library allows arbitrary file writes via symlinked node_modules, enabling code execution or data modification during npm install.

- **Severity:** High 8.2 (`CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 31 Aug 2021
- **Updated:** 4 Aug 2024
- **Also known as:** ALPINE-CVE-2021-39135, CLEANSTART-2026-IU52923, CLEANSTART-2026-JP73770, DEBIAN-CVE-2021-39135, GHSA-gmw6-94gg-2rc2, UBUNTU-CVE-2021-39135

## What is CVE-2021-39135?

CVE-2021-39135 is a high-severity path traversal vulnerability in Oracle Graalvm, published on 31 Aug 2021. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

`@npmcli/arborist`, the library that calculates dependency trees and manages the node_modules folder hierarchy for the npm command line interface, aims to guarantee that package dependency contracts will be met, and the extraction of package contents will always be performed into the expected folder. This is accomplished by extracting package contents into a project's `node_modules` folder. If the `node_modules` folder of the root project or any of its dependencies is somehow replaced with a symbolic link, it could allow Arborist to write package dependencies to any arbitrary location on the file system. Note that symbolic links contained within package artifact contents are filtered out, so another means of creating a `node_modules` symbolic link would have to be employed. 1. A `preinstall` script could replace `node_modules` with a symlink. (This is prevented by using `--ignore-scripts`.) 2. An attacker could supply the target with a git repository, instructing them to run `npm install --ignore-scripts` in the root. This may be successful, because `npm install --ignore-scripts` is typically not capable of making changes outside of the project directory, so it may be deemed safe. This is patched in @npmcli/arborist 2.8.2 which is included in npm v7.20.7 and above. For more information including workarounds please see the referenced GHSA-gmw6-94gg-2rc2.

Weakness: CWE-59 (Improper Link Resolution Before File Access), CWE-61 (UNIX Symbolic Link (Symlink) Following)

## Which versions are affected by CVE-2021-39135?

2 open source packages ship an affected version, including @npmcli/arborist. It affects 3 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@npmcli/arborist` | npm | All versions | 2.8.2 |
| `@npmcli/arborist` | npm | All versions | 2.8.2 |

Products: Npmjs Arborist, Oracle Graalvm, Siemens Sinec Infrastructure Network Services.

## How do I fix CVE-2021-39135?

Upgrade @npmcli/arborist to 2.8.2 or later.

## Is CVE-2021-39135 being exploited?

There is no known exploitation of CVE-2021-39135 in the wild and no public exploit code.

## Other vulnerabilities in Oracle Graalvm

- [CVE-2021-39134](https://insights.sbomify.com/CVE-2021-39134/): UNIX Symbolic Link (Symlink) Following in @npmcli/arborist (high 8.2)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-39135 and fix it if it is affected.

What it is: CVE-2021-39135 is a high-severity path traversal vulnerability in Oracle Graalvm, published on 31 Aug 2021. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2021-39135 in the wild and no public exploit code.

Affected packages and fixed versions:
- @npmcli/arborist (npm): affected all versions; fixed in 2.8.2
- @npmcli/arborist (npm): affected all versions; fixed in 2.8.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-39135/ (Markdown: https://insights.sbomify.com/CVE-2021-39135/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-39135
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-39135
- OSV: https://osv.dev/vulnerability/CVE-2021-39135

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-39135/
Summaries are generated and may contain mistakes; the official description above is the record.
